Rookie in incinga

Hello, I’ve been getting into Icinga2 for a few weeks.
I was trying to put a Windows host for the first time and I got this error (execvpe(
scp.exe) failed: No such file or directory)
Someone could help me. Thank you.

  • Icinga Web version 2.10.1
  • Ubuntu 20.04
  • Google Chrome
  • Icinga 2 version used 2.11.2
  • PHP version used 7.4.3

This issue looks similar to:

1 Like

And in what file do you have to put that and in ubuntu or in windows

Its a setting you can change in the director. For that you must locate the service template that your respective service uses.
In the web interface go to Icinga-Director → Services → Templates → The service you want to change
Then scroll down until you see “execute on agent”, enable this and roll out the new config.

Does this resolve the problem?

1 Like

I do not have director icinga since it gave me some failures. Is it mandatory if I want to put a windows host?

I dont think so, its makes your life alot easier however.
If you are not using the director then you should add “command_endpoint =” to the service file you are using.

1 Like

Look this is the error that throws me icinga director
I don’t know if you know what fault it could be.

Looks like the director cannot find the endpoint. Did you use the kickstart wizard yet?

1 Like

Icinga director install it with this link

I see, can you post your Icinga Director → Deployments → Infrastructure → Kickstart Wizard page?

1 Like


Yes, your kickstart wizard has not been run yet. This is how I do it:
Endpoint name: The hostname of your icinga server
Icinga host: The IP of your icinga server
API User and Password: The Api User you created during the icinga installation

Then run the import and do a config rollout.

1 Like

This is the error that I got, I have written down the usernames of everything that I have put and in the API user is the one that I put but I get this error

By the way thank you very much for helping

Your API User does not have sufficient rights. You can check your API Users in /etc/icinga2/conf.d/api-users.conf. What does that file say?

1 Like

This is embarrassing sorry I had the wrong password.
Now I get another error

Looks like the wizard cant connect to the icinga instance. I assume that you are using apache on the same server that hosts icinga? Can you check if your icinga endpoint is actually called “icinga_master” and did you run the node wizard from the terminal yet?

1 Like

how can i see all that?

Since you have icingaweb2 it would be very unusual to use two different server for icinga and apache, so I think we can cross that one out.
When settings up an icinga instance I (personally) use the following order:

  1. Installing Icinga2 + Web + Director
    You already did that
  2. Adjusting the director
    You already did that
  3. Node Wizard
    You probably did not do that yet, so here is the official how to
    (Distributed Monitoring - Icinga 2)
1 Like

Ok these days I’ll try that and I’ll post if it solves me or no, seriously thank you very much for the help :heart: