Icinga Web 2 interface changed after update

Hi everyone.

After a recent update to both of my icinga2 master servers, the web interface for one of them (Master1) has completely changed. When I log into Master1, I see all the same data I would see on Master2’s web interface, but the formatting is wildly different. For the sake of not exposing any network info, I’m posting a screenshot of the login page only.

How do I resolve this issue?

Both servers are running the same Icinga Web 2 version: 2.9.5
Both servers running CentOS 7, kernel version 3.10.0
Master1’s PHP version: 7.2.34
Master2’s PHP version: 5.4.16
Browsers: Attempted to view Master1’s web interface from Firefox, Chrome, and Edge. Same result on all three.

Please have a look here.

1 Like

Thanks for the reply. I don’t have the businessprocess module running and my vsphere module appears to be updated already. I’m not sure what else to try at this point.

Also, when I run

icingacli module list installed --verbose

I receive the following output.

director master enabled /usr/share/icingaweb2/modules/director
doc 2.9.5 enabled /usr/share/icingaweb2/modules/doc
grafana 1.2.1 disabled /usr/share/icingaweb2/modules/grafana
incubator v0.1.1 enabled /usr/share/icingaweb2/modules/incubator
ipl v0.1.1 enabled /usr/share/icingaweb2/modules/ipl
migrate 2.9.5 disabled /usr/share/icingaweb2/modules/migrate
monitoring 2.9.5 enabled /usr/share/icingaweb2/modules/monitoring
reactbundle v0.4.1 enabled /usr/share/icingaweb2/modules/reactbundle
reporting 0.0.0 enabled /usr/share/icingaweb2/modules/reporting
setup 2.9.5 disabled /usr/share/icingaweb2/modules/setup
translation 2.9.5 disabled /usr/share/icingaweb2/modules/translation
vspheredb 1.0.3 enabled /usr/share/icingaweb2/modules/vspheredb

ipl is way to old please remove it.

check if php-icinga is installed.

after that: disable everything except monitoring and try again.

continue enabling one module after another and logout clear browser cache and login again

reactbundle is deprecated → i think you wont need that anymore
reporting has a strange verison number please disable that too

1 Like

I ended up rolling this server back to a previous snapshot (before the update that messed up my web interface). I proceeded to only update security packages and icinga2, as opposed to ALL available packages (this server hasn’t been updated since 2019). The web interface is fine now, but when I try to view the modules I have installed, I receive this message:

director master enabled /usr/share/icingaweb2/modules/director
PHP Fatal error: Cannot declare class dipl\Loader\CompatLoader, because the name is already in use in /usr/share/icingaweb2/modules/director_old/library/vendor/ipl/Loader/CompatLoader.php on line 7
Fatal error: Cannot declare class dipl\Loader\CompatLoader, because the name is already in use in /usr/share/icingaweb2/modules/director_old/library/vendor/ipl/Loader/CompatLoader.php on line 7

How do I completely remove ipl and reactbundle? Is this just a matter of removing their directories/files?

That’s not the v1.0.4. v1.0.3 is not compatible with Icinga Web 2 v2.9.x.

Yes. But having them still installed does not hurt. They’re still required by some parts like older Director versions.

That error is due to the director being installed multiple times.

1 Like


In addition to the security and icinga2 updates, I updated php-Icinga. Immediately after, the web interface was displaying improperly again. I rolled php-Icinga back to the previous installation and the web interface is fine once again. I have no idea why this is the case. Master2 (which I’ve had no issues with) is running a more recent version of php-Icinga with no problems of any sort.

I’ve also noticed that since performing these updates, Master1’s website takes ridiculously long to load each page. I updated httpd, but still have the same issue.

And lastly, my ido2db service has failed on Master1.

● ido2db.service - LSB: Icinga IDO2DB Initscript
Loaded: loaded (/etc/rc.d/init.d/ido2db; bad; vendor preset: disabled)
Active: failed (Result: exit-code) since Thu 2022-01-13 17:39:08 HST; 2 weeks 5 days ago
Docs: man:systemd-sysv-generator(8)

Sorry if this is too much information for one post. I’ve taken over this icinga implementation a week ago and want to make sure I leave no stone unturned.

You may also have a theme active which causes problems.

This is a part from Icinga 1.x if I’m not mistaken. That was EOL long ago.


Good to know. Thank you!