After upgrade to 2.9.0 old modules not work

Hm, okay, then I’ll see this as solved for now. Didn’t hear of any similar issues yet.

@Edekrusher any updates on your part?

Im having the same issues, with visgence dependency module

Upgrade to last git will help. But many modules not “disable/enable” from web, it will not see monitoring plugin or director(master). But it can enabled from console “icingacli module enable …”

Also after Upgrade all charts seeing large. How do it normal size??))

I had the same appearance after upgrading, fixed it with a logout and login for me.

Yes. It’s work on first time on me too. But now i will reboot server. Del cookies. Anything not help )

To clear some things up:

  • Icinga Web 2 Version 2.9.0 introduced dependency checks for modules. If a module requires a dependency, this dependency needs to be installed and enabled first in order to enable the module.
    • If the Director is the dependency, and you have installed the master, consider installing the latest release instead. If you really have to use the master, your only chance is to enable the requiring module using the CLI tool.
  • The big pie charts are due to the use of an outdated stylesheet by your browser. Icinga Web 2 provides its own cache for this, so if you have your own cache set up, add an exclude rule for the stylesheet (and JS). If you don’t have an extra cache, Logout/Login may help as @aaron mentioned. You can also perform a force-refresh.

Browser Google chrome, no any unstandart settings. Cache will erased. Login/logout try. Not help

Hi!

I have the same issue, even the login doesn’t look good. Neither a reboot, logout, and login nor clear the cache doesn’t work.
I also tried a different browse (IE) and got the same picture.

I can Update the whole system but non of this packeges:

icingacli/icinga-focal,icinga-focal 2.9.0-1.focal all [aktualisierbar von: 2.8.2-1.focal]
icingaweb2-common/icinga-focal,icinga-focal 2.9.0-1.focal all [aktualisierbar von: 2.8.2-1.focal]
icingaweb2-module-doc/icinga-focal,icinga-focal 2.9.0-1.focal all [aktualisierbar von: 2.8.2-1.focal]
icingaweb2-module-monitoring/icinga-focal,icinga-focal 2.9.0-1.focal all [aktualisierbar von: 2.8.2-1.focal]
icingaweb2/icinga-focal,icinga-focal 2.9.0-1.focal all [aktualisierbar von: 2.8.2-1.focal]
php-icinga/icinga-focal,icinga-focal 2.9.0-1.focal all [aktualisierbar von: 2.8.2-1.focal]

The System is Ubuntu 20.04. based.

Thanks,

ThoWi

1 Like

The missing style (broken login) may be due the use of the businessprocess module < v2.3.1 or the vspheredb module < v1.0.4. Upgrade those and the style should be ok again.

If the monitoring module is also gone in your case, please show a full apt upgrade log.

1 Like

Hi Johannes,

Thanks a lot, the businessprocess module v2.3.0 causes the issue.
After update them to 2.3.1 all works fine again.

Thanks for your time and your support,

ThoWi

remove buisnessorocess and get new. In git typed 2.3.1. When make by manual from git I have branch master, but in icinga typed 2.3.0. vsheredb is 1.1.0. Problem still exist. reboot server and clean cache maked, but it don’t help

@Edekrusher Please share the output of the following command (Run it where Icinga Web 2 is installed):

icingacli module list installed --verbose

icingacli module list installed --verbose
MODULE VERSION STATE DIRECTORY
businessprocess 2.3.0 enabled /usr/share/icingaweb2/modules/businessprocess
cube 1.1.1 disabled /usr/share/icingaweb2/modules/cube
dependency_plugin 0.0.0 enabled /usr/share/icingaweb2/modules/dependency_plugin
director master enabled /usr/share/icingaweb2/modules/director
doc 2.9.0 disabled /usr/share/icingaweb2/modules/doc
grafana 1.4.2 disabled /usr/share/icingaweb2/modules/grafana
graphite 1.1.0 enabled /usr/share/icingaweb2/modules/graphite
icingadb 1.0.0-rc1 disabled /usr/share/icingaweb2/modules/icingadb
idoreports 0.9.1 enabled /usr/share/icingaweb2/modules/idoreports
incubator 0.6.0 enabled /usr/share/icingaweb2/modules/incubator
ipl v0.5.0 enabled /usr/share/icingaweb2/modules/ipl
lsd 1.0.1 disabled /usr/share/icingaweb2/modules/lsd
map 1.1.0 disabled /usr/share/icingaweb2/modules/map
mapDatatype 0.1.0 enabled /usr/share/icingaweb2/modules/mapDatatype
migrate 2.8.0 disabled /usr/share/icingaweb2/modules/migrate
monitoring 2.8.0 enabled /usr/share/icingaweb2/modules/monitoring
nagvis 1.1.1 disabled /usr/share/icingaweb2/modules/nagvis
pdfexport 0.9.1 enabled /usr/share/icingaweb2/modules/pdfexport
pnp 1.1.0 enabled /usr/share/icingaweb2/modules/pnp
reactbundle 0.7.0 enabled /usr/share/icingaweb2/modules/reactbundle
reporting 0.10.0 enabled /usr/share/icingaweb2/modules/reporting
setup 2.9.0 disabled /usr/share/icingaweb2/modules/setup
test 2.8.0 disabled /usr/share/icingaweb2/modules/test
translation 2.9.0 disabled /usr/share/icingaweb2/modules/translation
vsphere 1.1.0 enabled /usr/share/icingaweb2/modules/vsphere
vspheredb 1.1.0 disabled /usr/share/icingaweb2/modules/vspheredb
x509 1.0.0 enabled /usr/share/icingaweb2/modules/x509

I have something like this in my logs, i wonder if this is a related issue

<br />
<b>Fatal error</b>:  Uncaught Less_Exception_Parser: Expected ']' got 'i' in anonymous-file-0.less in /usr/share/icingaweb2/library/vendor/lessphp/lib/Less/Parser.php:2653
Stack trace:
#0 /usr/share/icingaweb2/library/vendor/lessphp/lib/Less/Parser.php(878): Less_Parser-&gt;Error('Expected ']' go...')
#1 /usr/share/icingaweb2/library/vendor/lessphp/lib/Less/Parser.php(1823): Less_Parser-&gt;expectChar(']')
#2 /usr/share/icingaweb2/library/vendor/lessphp/lib/Less/Parser.php(781): Less_Parser-&gt;parseAttribute()
#3 /usr/share/icingaweb2/library/vendor/lessphp/lib/Less/Parser.php(1694): Less_Parser-&gt;match(Array)
#4 /usr/share/icingaweb2/library/vendor/lessphp/lib/Less/Parser.php(1772): Less_Parser-&gt;parseElement()
#5 /usr/share/icingaweb2/library/vendor/lessphp/lib/Less/Parser.php(1751): Less_Parser-&gt;parseSelector(true)
#6 /usr/share/icingaweb2/library/vendor/lessphp/lib/Less/Parser.php(1867): Less_Parser-&gt;parseLessSelector()
#7 /usr/share/icingaweb2/library/vendor/lessphp/lib/Less/Parser.php(799): Less_Parser-&gt;parseRuleset()
#8 /usr/share/i in <b>/usr/share/icingaweb2/library/vendor/lessphp/lib/Less/Parser.php</b> on line <b>2653</b><br />

Downgrading to 2.8.4 fixes the issue.

in console google chrome errors:
icinga.min.js:15 GET http://icinga.monitor.trk.local/cube?dimensions=type&showSettings=0&showCompact=1 404 (Not Found)
send @ icinga.min.js:15
ajax @ icinga.min.js:15
loadUrl @ icinga.min.js:587
(anonymous) @ icinga.min.js:677
each @ icinga.min.js:15
each @ icinga.min.js:15
loadDashlets @ icinga.min.js:677
dispatch @ icinga.min.js:15
v.handle @ icinga.min.js:15
trigger @ icinga.min.js:15
(anonymous) @ icinga.min.js:15
each @ icinga.min.js:15
each @ icinga.min.js:15
trigger @ icinga.min.js:15
onInit @ icinga.min.js:674
dispatch @ icinga.min.js:15
v.handle @ icinga.min.js:15
trigger @ icinga.min.js:15
(anonymous) @ icinga.min.js:15
each @ icinga.min.js:15
each @ icinga.min.js:15
trigger @ icinga.min.js:15
initialize @ icinga.min.js:458
(anonymous) @ icinga.min.js:457
e @ icinga.min.js:15
t @ icinga.min.js:15
setTimeout (async)
(anonymous) @ icinga.min.js:15
c @ icinga.min.js:15
fireWith @ icinga.min.js:15
fire @ icinga.min.js:15
c @ icinga.min.js:15
fireWith @ icinga.min.js:15
ready @ icinga.min.js:15
B @ icinga.min.js:15
icinga.min.js:462 11:43:53.355 404 Not Found: Страница не найдена. Включение модуля “cube” может помочь!
writeToConsole @ icinga.min.js:462
error @ icinga.min.js:462
onFailure @ icinga.min.js:649
c @ icinga.min.js:15
fireWith @ icinga.min.js:15
l @ icinga.min.js:15
(anonymous) @ icinga.min.js:15
load (async)
send @ icinga.min.js:15
ajax @ icinga.min.js:15
loadUrl @ icinga.min.js:587
(anonymous) @ icinga.min.js:677
each @ icinga.min.js:15
each @ icinga.min.js:15
loadDashlets @ icinga.min.js:677
dispatch @ icinga.min.js:15
v.handle @ icinga.min.js:15
trigger @ icinga.min.js:15
(anonymous) @ icinga.min.js:15
each @ icinga.min.js:15
each @ icinga.min.js:15
trigger @ icinga.min.js:15
onInit @ icinga.min.js:674
dispatch @ icinga.min.js:15
v.handle @ icinga.min.js:15
trigger @ icinga.min.js:15
(anonymous) @ icinga.min.js:15
each @ icinga.min.js:15
each @ icinga.min.js:15
trigger @ icinga.min.js:15
initialize @ icinga.min.js:458
(anonymous) @ icinga.min.js:457
e @ icinga.min.js:15
t @ icinga.min.js:15
setTimeout (async)
(anonymous) @ icinga.min.js:15
c @ icinga.min.js:15
fireWith @ icinga.min.js:15
fire @ icinga.min.js:15
c @ icinga.min.js:15
fireWith @ icinga.min.js:15
ready @ icinga.min.js:15
B @ icinga.min.js:15
DevTools failed to load source map: Could not load content for http://icinga.monitor.trk.local/js/vis.map: HTTP error: status code 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE

This is a syntax error in the stylesheet by one of the modules you’ve installed.

The best way to track this down, is to disable each module one-by-one and load /icingaweb2/css/icinga.css in the browser after each. Once this doesn’t error anymore, you’ve found the erroneous module.

If it’s one made by Icinga, please open a bug report on Github.

1 Like

@Edekrusher

Thank you, after disabling the buisnessorocess modul - all is fine.

1 Like

Hello ,
This is the solution , its works after disabling the businesproess module

1 Like