After upgrade to 2.9.0 old modules not work

My icingaweb 2 will automatically update. And after this icingaweb will breaked. I will turn off all module and work will fine. But old modules: pnp, cube, buisnessprocess, idoreports, nagvis, vsphere not work. It typed: Unmet dependencies found! Module can’t be enabled unless all dependencies are met.

Модули monitoring>=2.4.1 * (not installed)
What i must do to work with modules, what i used all this time?

Please make sure to include the module name and version you cannot enable anymore.

The monitoring module seems to be completely missing. Is this true?

Which platform/distribution are you using?

I,m upgrade incubator from git to 0.6.0 and enable modules in console, now work fine. In web text " Unmet dependencies found! Module can’t be enabled unless all dependencies are met.

Модули monitoring>=2.4.1 * (not installed)" will state, but modules work. Platform Centos8 stream 64x

Please show a screenshot of Icinga Web 2’s about page.

And please show the path where Icinga Web 2 will load modules from and it’s contents. (e.g. ls -alF /usr/share/icingaweb2/modules)

Hi.

Just some quick notes:
Facing the same issues running at Ubuntu 18 (LTS).

Yes.

Additionally, problems with the icinga.min.css occur (saying wrong MIME-Type, because “text/html” was set and not “text/css”).
Icingaweb2 is unusable so (due a lack of time) I will restore a backup.


Greetings.

Please check the upgrading instructions. If you have the businessprocess module enabled, this also needs an upgrade.

1 Like

On purpose? I mean, if it’s missing but required it is no wonder why it cannot simply be enabled.

Hi again.

No, not on purpose. It seems that it disappeared after the upgrade via apt.
It was in the nightly backup, so it could be simply restored.

However, I couldn’t see any operations in the apt history or the deb-packages I looked at, which may have caused this.
Maybe I missed something, but I am quite sure that you can ignore my previous answer.


Greetings

Hm, okay, then I’ll see this as solved for now. Didn’t hear of any similar issues yet.

@Edekrusher any updates on your part?

Im having the same issues, with visgence dependency module

Upgrade to last git will help. But many modules not “disable/enable” from web, it will not see monitoring plugin or director(master). But it can enabled from console “icingacli module enable …”

Also after Upgrade all charts seeing large. How do it normal size??))

I had the same appearance after upgrading, fixed it with a logout and login for me.

Yes. It’s work on first time on me too. But now i will reboot server. Del cookies. Anything not help )

To clear some things up:

  • Icinga Web 2 Version 2.9.0 introduced dependency checks for modules. If a module requires a dependency, this dependency needs to be installed and enabled first in order to enable the module.
    • If the Director is the dependency, and you have installed the master, consider installing the latest release instead. If you really have to use the master, your only chance is to enable the requiring module using the CLI tool.
  • The big pie charts are due to the use of an outdated stylesheet by your browser. Icinga Web 2 provides its own cache for this, so if you have your own cache set up, add an exclude rule for the stylesheet (and JS). If you don’t have an extra cache, Logout/Login may help as @aaron mentioned. You can also perform a force-refresh.

Browser Google chrome, no any unstandart settings. Cache will erased. Login/logout try. Not help

Hi!

I have the same issue, even the login doesn’t look good. Neither a reboot, logout, and login nor clear the cache doesn’t work.
I also tried a different browse (IE) and got the same picture.

I can Update the whole system but non of this packeges:

icingacli/icinga-focal,icinga-focal 2.9.0-1.focal all [aktualisierbar von: 2.8.2-1.focal]
icingaweb2-common/icinga-focal,icinga-focal 2.9.0-1.focal all [aktualisierbar von: 2.8.2-1.focal]
icingaweb2-module-doc/icinga-focal,icinga-focal 2.9.0-1.focal all [aktualisierbar von: 2.8.2-1.focal]
icingaweb2-module-monitoring/icinga-focal,icinga-focal 2.9.0-1.focal all [aktualisierbar von: 2.8.2-1.focal]
icingaweb2/icinga-focal,icinga-focal 2.9.0-1.focal all [aktualisierbar von: 2.8.2-1.focal]
php-icinga/icinga-focal,icinga-focal 2.9.0-1.focal all [aktualisierbar von: 2.8.2-1.focal]

The System is Ubuntu 20.04. based.

Thanks,

ThoWi

1 Like

The missing style (broken login) may be due the use of the businessprocess module < v2.3.1 or the vspheredb module < v1.0.4. Upgrade those and the style should be ok again.

If the monitoring module is also gone in your case, please show a full apt upgrade log.

Hi Johannes,

Thanks a lot, the businessprocess module v2.3.0 causes the issue.
After update them to 2.3.1 all works fine again.

Thanks for your time and your support,

ThoWi