[Grafana] iFrame but no Graphs are shown - "host refused to connect"

Hello everyone, this is kinda a follow up to my previous post which was solved.
Now that I finally didn’t have the problem anymore of a self signed certificate and the link and everything is right my graphs from grafana are still not showing up - in a very confusing way.

I’ve seen this problem similar to mine in the general problem of the links being right but no display. I am working with iFrame already which was kinda the solution in the other thread and I implemented the solution from that thread already. But it still doesn’t work.

So this is my setup:

Grafana and Version etc:

Grafana Configuration:

The Service view:

As far as I have checked:

  • the link that should lead to the graph does lead to the right Grafana graph in request (manually)
  • the request for the graph is never noticed on the influxdb-server (request not send?), seen through logs
  • all Grafana rendering and Render are installed with dependencies
  • the host can reach the influxdb-server through ping
  • I found this Error in the developer tools:
Refused to display '<URL>' in a frame because it set 'X-Frame-Options' to 'deny'.

Found the solution:
You have to set the Option allow_embedding=true on the database/grafana server in the /etc/grafana/grafana.ini!