A week ago I recognized that my icingadb doesnt really point on my redis.
In the Icingaweb2 module tab was the ip from the icinga master wich we i changed to the IP-address of the DB-Node.
Since that change my IcingaDB Service crash randomly multiple times a day.
The Error Message
Aug 17 11:57:25 RZHROMONITORDB icingadb[130103]: config-sync: Inserting 1187 items of type host
Aug 17 11:57:24 RZHROMONITORDB icingadb[130103]: Starting initial state sync
Aug 17 11:57:24 RZHROMONITORDB icingadb[130103]: Starting overdue sync
Aug 17 11:57:24 RZHROMONITORDB icingadb[130103]: Starting config sync
Aug 17 11:57:24 RZHROMONITORDB icingadb[130103]: Taking over
Aug 17 11:57:24 RZHROMONITORDB icingadb[130103]: heartbeat: Received Icinga heartbeat
Aug 17 11:57:24 RZHROMONITORDB icingadb[130103]: Starting history sync
Aug 17 11:56:58 RZHROMONITORDB icingadb[130103]: Waiting for Icinga 2 to write into Redis, please make sure you have started Icinga 2 and the Icinga DB feature is enabled
Aug 17 11:56:55 RZHROMONITORDB icingadb[130103]: Connecting to Redis at 'redis://localhost:6380'
Aug 17 11:56:55 RZHROMONITORDB icingadb[130103]: Connecting to database at 'mysql://icingadb@localhost:3306/icingadb'
Aug 17 11:56:55 RZHROMONITORDB icingadb[130103]: Starting Icinga DB daemon (v1.5.1)
Aug 17 11:56:55 RZHROMONITORDB systemd[1]: Started icingadb.service - Icinga DB.
Aug 17 11:56:55 RZHROMONITORDB systemd[1]: Starting icingadb.service - Icinga DB...
Aug 17 11:55:02 RZHROMONITORDB systemd[1]: icingadb.service: Consumed 33.484s CPU time.
Aug 17 11:55:02 RZHROMONITORDB systemd[1]: icingadb.service: Failed with result 'exit-code'.
Aug 17 11:55:02 RZHROMONITORDB systemd[1]: icingadb.service: Main process exited, code=exited, status=1/FAILURE
Aug 17 11:55:02 RZHROMONITORDB icingadb[128582]: unexpected Redis schema version: "5" (expected "6"), please make sure you are running compatible versions of Icinga 2 and Icinga DB
Aug 17 11:55:02 RZHROMONITORDB icingadb[128582]: Icinga 2 started a new config dump, waiting for it to complete
Aug 17 11:55:02 RZHROMONITORDB icingadb[128582]: config-sync: Deleting 11002 items of type notification recipient
After restarting the icingadb.service the db is running again but crash after several hours.
! corrention !
The icingadb carshes if someon deploys with the Icinga-Director. 20 seconds after rollout the icingadb.services crashes
Montag, 17. August 2026
[admin.xy modify service "systemd" 17:13:18
[admin.abc] modify host "Host162" 11:54:46
[admin.abc] modify host "Host162" 10:50:56
╰─# journalctl -u icingadb --since "2026-08-17 10:00" -f | grep Failed -C 3
Aug 17 10:51:13 RZHROMONITORDB icingadb[23493]: config-sync: Updating 1187 items of type host state
Aug 17 10:51:14 RZHROMONITORDB icingadb[23493]: unexpected Redis schema version: "5" (expected "6"), please make sure you are running compatible versions of Icinga 2 and Icinga DB
Aug 17 10:51:14 RZHROMONITORDB systemd[1]: icingadb.service: Main process exited, code=exited, status=1/FAILURE
Aug 17 10:51:14 RZHROMONITORDB systemd[1]: icingadb.service: Failed with result 'exit-code'.
Aug 17 10:51:14 RZHROMONITORDB systemd[1]: icingadb.service: Consumed 1h 9min 21.985s CPU time.
Aug 17 10:59:24 RZHROMONITORDB systemd[1]: Starting icingadb.service - Icinga DB...
Aug 17 10:59:24 RZHROMONITORDB icingadb[127288]: Starting Icinga DB daemon (v1.5.1)
--
Aug 17 11:55:02 RZHROMONITORDB icingadb[128582]: Icinga 2 started a new config dump, waiting for it to complete
Aug 17 11:55:02 RZHROMONITORDB icingadb[128582]: unexpected Redis schema version: "5" (expected "6"), please make sure you are running compatible versions of Icinga 2 and Icinga DB
Aug 17 11:55:02 RZHROMONITORDB systemd[1]: icingadb.service: Main process exited, code=exited, status=1/FAILURE
Aug 17 11:55:02 RZHROMONITORDB systemd[1]: icingadb.service: Failed with result 'exit-code'.
Aug 17 11:55:02 RZHROMONITORDB systemd[1]: icingadb.service: Consumed 33.484s CPU time.
Aug 17 11:56:55 RZHROMONITORDB systemd[1]: Starting icingadb.service - Icinga DB...
Aug 17 11:56:55 RZHROMONITORDB systemd[1]: Started icingadb.service - Icinga DB.
--
Aug 17 17:13:33 RZHROMONITORDB icingadb[130103]: Icinga 2 started a new config dump, waiting for it to complete
Aug 17 17:13:33 RZHROMONITORDB icingadb[130103]: unexpected Redis schema version: "5" (expected "6"), please make sure you are running compatible versions of Icinga 2 and Icinga DB
Aug 17 17:13:33 RZHROMONITORDB systemd[1]: icingadb.service: Main process exited, code=exited, status=1/FAILURE
Aug 17 17:13:33 RZHROMONITORDB systemd[1]: icingadb.service: Failed with result 'exit-code'.
Aug 17 17:13:33 RZHROMONITORDB systemd[1]: icingadb.service: Consumed 4min 47.235s CPU time.
Aug 17 17:16:41 RZHROMONITORDB systemd[1]: Starting icingadb.service - Icinga DB...
Aug 17 17:16:41 RZHROMONITORDB icingadb[139584]: Starting Icinga DB daemon (v1.5.1)
The MariaDB schema is 1.4.0 and i migrated the MariaDB several months befor.
I have split up my setup to a master node, DB Node (MariaDB, Redis, IcingaDB, Influx) and Icingaweb2 Node.
The Icingadb module is enabled on both the Icinga Master and the DB Node.
Befor I thought i fixed it couse there are two entrys in the Redis.ini pointing at the master and the DB but now we recognized that this happen on more than one system that after deploying the Icingdb crashes (my case) or need some time to load (client)
Versions
icinga2 - The Icinga 2 network monitoring daemon (version: r2.16.4-1)
Icinga DB version: v1.5.1 (both master and DB)
mariadb Ver 15.1
icingadb-redis 8.2.8-1+debian12
icingadb-redis-server 7.0.15-1+debian12
Maybe there are some old apckets or other apps installed on the master interferring with the redis/IcingaDB. After restarting the icingdb on the DB host its start waiting for a hearthbeat and only after you resatart the master it begins working (screenshot).
config on the Icinga master
╰─# cat /etc/icinga2/features-enabled/icingadb.conf
object IcingaDB "icingadb" {
host = "10.1.68.3" #DB-Host
port = 6380
//password = "xxx"
}
We also stopped the icinga2.service and the icingadb.service and flushed the redis server without anny succes.
icingadb-redis-cli flushall
Did i miss something?

