Process information: icinga is currently not rup and running

You just need to reload icinga2. If the table is still empty, then your IDO is not working properly or IDO is not enabled. The latter you can check with:

icinga2 feature list

Hi Sommer

Below are the features enabled.

api.conf, checker.conf, command.conf, ido-pgsql.conf, logfile, mainlog.conf, notiifcation.conf, perfdata.conf

And ido-pgsql.conf is as below

  • The IdoPgsqlConnection type implements PostgreSQL support
  • for DB IDO.
    */

object IdoPgsqlConnection “ido-pgsql” {
user = “icinga”
password = “xxxxxx”
host = “localhost”
database = “icinga”

}

Also, I forgot to mention, this is my fresh installation of icinga

Thanks&Regards
Srinivas

Have you already tried to login with that credentials to the database? Any hints in the icinga logs?

Hi

Below is the icinga2.log file message

(IdoPgsqlConnection, ido-pgsql) items: 1, rate: 2/s (120/min 638/5min 1304/15min);
[2020-01-13 11:58:03 +0100] critical/IdoPgsqlConnection: Connection to database ‘icinga’ with user ‘icinga’ on ‘localhost:5432’ failed: "could not connect to server: Connection refused
Is the server running on host “localhost” (127.0.0.1) and accepting
TCP/IP connections on port 5432?

But in resources.ini file, I have changed the port 5432 to different port

I could login to database. Below is the sample query i tried connecting to pgsql

icinga=> select status_update_time from icinga_programstatus;
status_update_time

(0 rows)

Thanks&Regards
Srinivas

Ah, then you need the port definition in your ido-pgsql.conf.

Hi

Thank you

I updated ido_pgsql.conf file adding port and restarted icinga and apache services. Still, no hosts is dispalyed in web console. same message “icinga is currently not up and running”

  • The IdoPgsqlConnection type implements PostgreSQL support
  • for DB IDO.
    */

object IdoPgsqlConnection “ido-pgsql” {
user = “icinga”
password = “xxxxxx”
host = “localhost”
port = “xxxxx”
database = “icinga”

}

Thanks&Regards
Srinivas

Anything in the logs?

Hi

Below is the log content

[2020-01-13 14:18:25 +0100] critical/IdoPgsqlConnection: Connection to database ‘icinga’ with user ‘icinga’ on ‘localhost:5432’ failed: "could not connect to server: Connection refused
Is the server running on host “localhost” (127.0.0.1) and accepting
TCP/IP connections on port 5432?
"
Context:
(0) Reconnecting to PostgreSQL IDO database ‘ido-pgsql’

[2020-01-13 14:18:25 +0100] warning/IdoPgsqlConnection: Exception during database operation: Verify that your database is operational!
[2020-01-13 14:18:27 +0100] warning/PluginCheckTask: Check command for object ‘localhost!ping4’ (PID: 72983, arguments: ‘/icinga2/icinga/usr/lib/nagios/plugins/check_ping’ ‘-4’ ‘-H’ ‘127.0.0.1’ ‘-c’ ‘200,15%’ ‘-w’ ‘100,5%’) terminated with exit code 128, output: execvpe(/icinga2/icinga/usr/lib/nagios/plugins/check_ping) failed: No such file or directory

I just replaced hostname by “localhost” in the above content otherwise everything is as it is.

Thanks&Regards
Srinivas

IDO tries to connect on the default port and not at your customized port. Could you share

icinga2 object list -n ido-pgsql

The path is completely wrong, I’d assume you change ConfigDir constant to wrong value.

Hi

The issue is resolved after making changes as you suggested .

changing the port to customized port
also changed the username and password to the actual values I gave during database setup.

Now, console is showing the host and the issues

One issue is resolved

Now, I could see on icinga web the below issue under services.

execvpe(/icinga2/icinga/usr/lib/nagios/plugins/check_ping) failed: No such file or directory

I just verified the constans.conf file and could see the below. There paths were defined by default.

const PluginContribDir = “/icinga2/icinga/usr/lib/nagios/plugins”
const ManubulonPluginDir = "/icinga2/icinga/usr/lib/nagios/plugins

Do I need to change anything here

Thanks&Regards
Srinivas

Adding to above

on console below is the issue is displayed

execvpe(/icinga2/icinga/usr/lib/nagios/plugins/check_disk) failed: No such file or directory

the default constants.conf looks like:

/**
 * This file defines global constants which can be used in
 * the other configuration files.
 */

/* The directory which contains the plugins from the Monitoring Plugins project. */
const PluginDir = "/usr/lib/nagios/plugins"

/* The directory which contains the Manubulon plugins.
 * Check the documentation, chapter "SNMP Manubulon Plugin Check Commands", for details.
 */
const ManubulonPluginDir = "/usr/lib/nagios/plugins"

/* The directory which you use to store additional plugins which ITL provides user contributed command definitions for.
 * Check the documentation, chapter "Plugins Contribution", for details.
 */
const PluginContribDir = "/usr/lib/nagios/plugins"
...

Hi

Actually, we have used custom paths (as per customer requirement) so the path is different.

I just verified the plugins

/icinga2/icinga/usr/lib/nagios/plugins

under this path I could see only one file “check_nscp_api”

Is this correct?

As per above issue, icinga is looking for check_disk under plungins which is not avaialble.

Please suggest me if I need to make any changes

Thanks&Regards
Srinivas

You need to make sure that the path to the plugins correspond to the constants. If there are some plugins missing in that directory, you need to copy/install them.

Hi

Thank you so much for your support.

I shall install the missing pulgins and ensure the correct path.

Thanks&Regards
Srinivas

Hi

I installed missing nagios plugins and copy them in the correct path.

Now that issue is gone.

Thanks for the support

Thanks&Regards
Srinivas

Hi @srinivas
two small requests for future topics/posts:
In future please use the markdown options to format your posts, especially if they contain code/config/log snippets. This way you make it easier for people trying the help reading your posts :slight_smile:
Here you can find a HowTo for this:

Also please pick a solution to topic that have been successfully solved.
This way you can “reward” the solution author and visibly mark the topic as solved :slight_smile:

Hello Community

I freshly installed Icinga2 and have the same problem: “icinga is currently not up and running”.

  1. OS: Red Hat 7
  2. Used guide : https://www.vultr.com/docs/how-to-install-icinga-2-and-icinga-web-2-on-centos-7
  3. select status_update_time from icinga_programstatus; > returns 0 rows
  4. icingacli module list > returns only ‘Monitoring’
  5. grep -i -r ‘fail|error|refuse’ /var/log/icinga2/ > returns 0 rows

Kind request for guidance?

Regards, Aleksander

Hi & welcome to the community,

I’d recommend to not follow up in an old thread as this will most probably not be read by many people.

Regarding your question: Check if ido is configured properly and enabled (details can be found here).

1 Like

Hi Roland

Thanks for the tip, i checked all the steps, few times.
Will start a new thread then