Icingaweb2-module-monitoring update deletes module

After update my Icinga2 server the icingaweb2-module-monitoring is gone. There are only docs in the package. What did I miss?

ii icingaweb2-module-monitoring 2.11.4-1+debian11 all Empty transition package

root@s012:/etc/icingaweb2/enabledModules# dpkg -L icingaweb2-module-monitoring

Give as much information as you can, e.g.

Icinga Web 2 Version 2.11.3
Git Commit f917436a894c1f4148a9c3d6a27f9c20f204e44f
PHP-Version 7.4.33
Git Commit Datum 2022-12-14

Geladene Bibliotheken

icinga/icinga-php-thirdparty 0.11.0
icinga/icinga-php-library 0.10.1

Geladene Module

director 1.9.1
fileshipper 1.2.0
incubator 0.17.0
ipl v0.5.0
monitoring 0.0.0
nordlicht 1.0.0
reactbundle 0.9.0
spring 0.0.1
  • Web browser used: Firefox ESR 102.7.0
  • Icinga 2 version used (icinga2 --version)

icinga2 - The Icinga 2 network monitoring daemon (version: r2.13.6-1)

System information:
Platform: Debian GNU/Linux
Platform version: 11 (bullseye)
Kernel: Linux
Kernel version: 5.10.0-21-amd64
Architecture: x86_64

Build information:
Compiler: GNU 10.2.1
Build host: runner-hh8q3bz2-project-575-concurrent-0
OpenSSL version: OpenSSL 1.1.1n 15 Mar 2022

root@s012:~# tail /var/log/icingaweb2/icingaweb2.log
2023-01-30T18:48:29+01:00 - WARNING - Found invalid module in enabledModule directory "/etc/icingaweb2/enabledModules": "/etc/icingaweb2/enabledModules/monitoring" points to non existing path "false"
2023-01-30T18:48:30+01:00 - WARNING - Found invalid module in enabledModule directory "/etc/icingaweb2/enabledModules": "/etc/icingaweb2/enabledModules/monitoring" points to non existing path "false"

The symlink to module folder is missing

root@s012:/etc/icingaweb2/enabledModules# ls -alh /usr/share/icingaweb2/modules/
insgesamt 56K
drwxr-xr-x 14 root root 4,0K 30. Jan 18:47 .
drwxr-xr-x  9 root root 4,0K 21. Nov 2020  ..
drwxr-xr-x 12 root root 4,0K  8. Apr 2022  director
drwxr-xr-x  6 root root 4,0K 17. Dez 06:48 doc
drwxr-xr-x  7 root root 4,0K  9. Aug 2021  fileshipper
drwxr-xr-x  7 root root 4,0K 20. Jun 2022  incubator
drwxr-xr-x  6 root root 4,0K 22. Nov 2020  ipl
drwxr-xr-x  4 root root 4,0K 17. Dez 06:48 migrate
drwxr-xr-x  5 root root 4,0K 24. Dez 2020  nordlicht
drwxr-xr-x  6 root root 4,0K 16. Feb 2021  reactbundle
drwxr-xr-x  5 root root 4,0K 17. Dez 06:48 setup
drwxr-xr-x  5 root root 4,0K 24. Dez 2020  spring
drwxr-xr-x  3 root root 4,0K 17. Dez 06:48 test
drwxr-xr-x  5 root root 4,0K 17. Dez 06:48 translation


The monitoring and doc package are now included in the icingaweb2 package for debian, try to reinstall icingaweb2, maybe the update happened before the removal of the monitoring module pkg and caused the issue.


Just had this on a customer system as well where the auto-update via cron didn’t work and only the icingaweb2-module-monitoring package was updated.

A apt update && apt upgrade installed icingaweb2 and removed the monitoring and doc package.
After that the webinterface worked normally again.

was this announced anywhere?

1 Like

Apt upgrade broke my system as well. I did an apt remove and apt install icingaweb2-module-monitoring and the Dashboard is working again, however Director is now broken, and Configuration is no longer in the left navigation pane.

Director error:

Uncaught Error: Class ‘Icinga\Util\Translator’ not found in /usr/share/icingaweb2/modules/incubator/vendor/gipfl/icingaweb2/src/Translator.php:20
Stack trace:
#0 /usr/share/icingaweb2/modules/incubator/vendor/gipfl/translation/src/TranslationHelper.php(17): gipfl\IcingaWeb2\Translator->translate()
#1 /usr/share/icingaweb2/modules/director/library/Director/Web/Tabs/MainTabs.php(26): Icinga\Module\Director\Web\Tabs\MainTabs->translate()
#2 /usr/share/icingaweb2/modules/director/application/controllers/DashboardController.php(55): Icinga\Module\Director\Web\Tabs\MainTabs->__construct()
#3 /usr/share/icingaweb2/modules/director/application/controllers/IndexController.php(42): Icinga\Module\Director\Controllers\DashboardController->indexAction()
#4 /usr/share/icingaweb2/library/vendor/Zend/Controller/Action.php(507): Icinga\Module\Director\Controllers\IndexController->indexAction()
#5 /usr/share/php/Icinga/Web/Controller/Dispatcher.php(76): Zend_Controller_Action->dispatch()
#6 /usr/share/icingaweb2/library/vendor

#0 [internal function]: Icinga\Application\Web->Icinga\Application{closure}()
#1 {main}

We’re currently looking into it.

Meanwhile, if you experience this issue already and can’t help yourself out, try downgrading to icingaweb2 2.11.3-2.

I was wrong about Configuration no longer being visible. I forgot it’s down at the bottom in the gear icon.

I was able to fix my problems with Director by doing:

apt-get install icinga-php-incubator icingacli

So all appears to be well on my installation now…

Please Help!!!

After upgrade the Icingaweb2 (version: r2.13.6-1) the CSS doesnt work and monitoring stop work, the GUI got the error

Cannot load resource config “icinga2”. Resource does not exist

#0 /usr/share/icingaweb2/modules/monitoring/library/Monitoring/Backend/MonitoringBackend.php(208): Icinga\Data\ResourceFactory::getResourceConfig(String) #1 /usr/share/icingaweb2/modules/monitoring/library/Monitoring/Backend/MonitoringBackend.php(287): Icinga\Module\Monitoring\Backend\MonitoringBackend->getResource() #2 /usr/share/icingaweb2/modules/monitoring/library/Monitoring/DataView/DataView.php(55): Icinga\Module\Monitoring\Backend\MonitoringBackend->query(String, Array) #3 /usr/share/icingaweb2/modules/monitoring/library/Monitoring/Backend/MonitoringBackend.php(242): Icinga\Module\Monitoring\DataView\DataView->__construct(Object(Icinga\Module\Monitoring\Backend\Ido\IdoBackend), Array) #4 /usr/share/icingaweb2/modules/monitoring/application/controllers/ListController.php(85): Icinga\Module\Monitoring\Backend\MonitoringBackend->from(String, Array) #5 /usr/share/icingaweb2/library/vendor/Zend/Controller/Action.php(507): Icinga\Module\Monitoring\Controllers\ListController->hostsAction() #6 /usr/share/php/Icinga/Web/Controller/Dispatcher.php(76): Zend_Controller_Action->dispatch(String) #7 /usr/share/icingaweb2/library/vendor/Zend/Controller/Front.php(937): Icinga\Web\Controller\Dispatcher->dispatch(Object(Icinga\Web\Request), Object(Icinga\Web\Response)) #8 /usr/share/php/Icinga/Application/Web.php(290): Zend_Controller_Front->dispatch(Object(Icinga\Web\Request), Object(Icinga\Web\Response)) #9 /usr/share/php/Icinga/Application/webrouter.php(105): Icinga\Application\Web->dispatch() #10 /usr/share/icingaweb2/public/index.php(4): require_once(String) #11 {main}

We tried everything and doesn’t work.

The Icinga2 is installed on
System information:
Platform: Debian GNU/Linux
Platform version: 10 (buster)
Kernel: Linux
Kernel version: 4.19.0-23-amd64
Architecture: x86_64

PHP 7.3

That’s the version of Icinga 2 not Icinga Web 2.
But I’m guessing the update installed icingaweb2 in v2.11.4 as well.

Check if the icingaweb2* packages are all installed in v2.11.4 or if there are any missing.
You can also try downgrading to v2.11.3 like @nilmerg mentioned.

And if you can specify this further it would be helpful :wink:

also: please don’t double-post the same problem in two separate threads at once

Sorry the late reply. I was on the road all week and had restored the folder from backup, so that is was functionally on my site.

Thanks @moreamazingnick, that was the solution. After reinstalling the folder /usr/share/icingaweb2/modules/monitoring was there again and the web interface was functionally again.

1 Like

The upgrade to v2.11.4 can now safely be performed without worrying that the monitoring module gets removed.