ICINGA2 & GRAFANA Integration

recently I have updated ICINGA and moved to ICINGADB
(Now I can access both ICINGADB Menu than Classic Overview")

Before moving to ICINGADB I was able to see GRAFANA performance graph into the service details:
Like this:

NOW If I try to view the service details from “Overview” - There is no graph at all
If I goes into ICINGADB Menu I can see a broken image:


Debut (enabled) do not show so much:

Do I have to perform some post migration activities (after move to ICINGADB) ?

If I’m correct the Grafana module can only work with the monitoring module or the IcingaDB module, there isn’t a version that works with both. So if you update the module it will stop working in the classical monitoring module that is IDO based.


But in my case it do not work at all.

Not in the OLD UI nor in the New one.

NOw I have this error (From Service Check View in IcingaDB menu):

I have a “connection refused” but my GRAFANA installation is on the same host of ICINGA…


Did you play with https://github.com/Mikesch-mp/icingaweb2-module-grafana/blob/master/doc/03-module-configuration.md#accessmode ?

I 'm using iFrame…
I have added the
allow_embedding = true

restarted grafana
But NO CHANGE… still connection refused

hm, works for me with version 2.0.3 of the grafana module

I have the version 2.0.0b

Updated to 2.0.3 - NO CHANGE.
Still have a “refused to connect.” error

using FIREFOX I have ad additional INFO.
Seens to be something related to “embedded” content into the web page:

My ICINGA (icingaweb2) site is HTTP and even the GRAFANA SITE (that is on the same host) is HTTP.
I have configured GRAFANA MODULE to use HTTP (not HTTPS).

Looking into CHROME Dev Tool I found:

Refused to display ‘http://icinga2.locale:3000/’ in a frame because it set ‘X-Frame-Options’ to ‘deny’.

How can I “ALLOW” X-Frame-Options ?

I Found this:

And this HELP!

1 Like