Icinga backend not running

Hey. Im still suffering the consequences of my earlier reported power outage.

Today i tried to install my databases back onto the same system thats running icinga. Purging mariadb did indeed fix the problems i had with mariadb so i recreated my databases and users and then imported my sqldumps.

Finally i changed the resources in the icinga webfrontend from my external db server to localhost.
The setting check worked and icinga seemed to accept the databases.

But then “icinga backend not running” popped up. Restarting, rebooting and even changing the db server back to the external one does not fix this.

I followed this threads suggestions


but i ended up with the same error as op and thats where the thread ends.

I would really appreciate any help or pointers. Im still rather new to all this so please bear with me.

Hello @why!

Compare the Icinga Web DB resource the monitoring backend uses with /etc/icinga2/features-available/ido-mysql.conf. Do they target the same database?


1 Like

Oh my god, thank you so much. Icinga is now finally running again. It doesnt show any hosts right now, eventhough theyre in the db, but this is a big help and progress. Thank you!!!