Execvpe( scp.exe) failed: No such file or directory

Hello, I’ve been getting into Icinga2 for a few weeks.
I was trying to put a Windows host for the first time and I got this error (execvpe(
scp.exe) failed: No such file or directory)
Someone could help me. Thank you.

  • Icinga Web version 2.10.1
  • Ubuntu 20.04
  • Google Chrome
  • Icinga 2 version used 2.11.2
  • PHP version used 7.4.3

Give us some information to be able to reproduce the problem.

  1. At what point do you get this error message? What did you just do which
    causes it?

  2. How are you monitoring this Windows machine? What service checks have you
    configured?

  3. Which instructions (provide URL?) did you follow to get Icinga installed on
    the Windows machine?

  4. Which version of Windows is the machine running?

Antony.

My Windows version is Windows 10 Pro. I used the official Icinga instructions.
I get the error message when I put it in the Ubuntu server to be able to monitor Windows. I was trying to monitor the RAM of the Windows client

Please explain exactly what you mean by “I get the error message when I put it
in the Ubuntu server to be able to monitor Windows.”

Show us what the configuration looks like, tell us what command you are typing,
or somehow else give us enough information to be able to reproduce the problem
for ourselves.

We need to know exactly what you are doing in order to be able to suggest what
you should be doing instead.

Antony.

host
This is the host.conf file
services
This is the services.conf file

Hello @AdrianNetancor,
Welcome to the Icinga community. Your client_endpoint is missing in your host object for your apply rules to work.

Try this

object Host "Pruebase3" {
  address = "10.0.10.25"
  vars.os = "Windows"
  vars.client_endpoint = name
}

Regards
Alex

Good, when trying that I get this error.
errorHost

I’m not sure what error message is showing. Is your Icinga conf correct? Run ‘icinga2 daemon -C’ to confirm your Icinga conf files are correct. If you config is correct than restart you icinga2 service.

object Host "Pruebase3" {
  address = "10.0.10.25"
  check_command = "hostalive4"
  vars.os = "Windows"
  vars.client_endpoint = name
}

apply Service "nscp-local-cpu" {
  check_command = "nscp-local-cpu"
  command_endpoint = host.vars.client_endpoint
  vars.nscp_cpu_showall = true
assign where host.vars.os == "Windows"
}

I was trying what you gave me and it keeps giving me an error look
error daemon
Error daemon
error journe

Do you have your object endpoint and zone defined for host Pruebase3?

host_Pruebase3.conf

object Endpoint "Pruebase3" {
  host = "10.0.10.25"
  port = 5665
  log_duration = 1d
}

object Zone "Pruebase3" {
  endpoints = [ "Pruebase3" ]
  parent = "master"
}

object Host "Pruebase3" {
  address = "10.0.10.25"
  check_command = "hostalive4"
  vars.os = "Windows"
  vars.client_endpoint = name
}

Can you please use better formatting in your post. Its hard to see the pictures. Can you please add all code with three back ticks before and after code ( key to left of number 1 on English keyboard). This will help when view code blocks. Examples are here.

Regards
Alex

I don’t know what you mean by the master if you mean the zones.conf file is this.
zonesconf

Okay, lets start over. Your original post said.

Append the text below to your constants.conf file on your Windows host and restart the Icinga2 service on your Windows host. This has resolved this error for me on my Windows host.

/* The directory contains the local NSClient++ plugins
* This resolved error - scp.exe, The system cannot find the file specified.
*/
const NscpPath = "C:\\Program Files\\NSClient++"

Hello, I was trying what you told me and pinging worked for me but I want to know the ram of the equipment and with that it keeps giving me an error. Same old Execvpe( scp.exe) failed: No such file or directory

Can you please share the zone.conf & constants.conf file from your Windows host (Pruebas3)?