Business modeling process issue icingaweb2

Hi , Basically I am using ICINGAWEB2 . Versions are specified
icinga/icinga-php-library 0.9.1
icinga/icinga-php-thirdparty 0.11.0
PHP 8.0

I have tried to clone the business process module 2.4 and 2.3 but when ever I enable the module in the enviromnet the UI breaks.

I dont know the reason can any one help me in this

For PHP 8 you need version 2.4 of the module.
Is you Icinga Web 2 on at least v2.9 so that it meets the requirements of the module?
Did you try a cache refresh of the page (Ctrl+F5 or Ctrl+Shift+R)?

I have not tried but I will and update you

Hi bro I have tried this But the UI keeps on breaking after enablement of module. I am using RHEL 8 as a base OS and on top of that i have installed Icinga web2 2.9.5. Since the version more than 2.9.5 is available in RHEL repository of icinga which they have provided. So please guide me what to do seriously I am in a pickle regarding this situation and i need to enable the business module so thats why its a request that if you can help me in this.

THanks and sorry for bothering you

Hi there

not at all, the community is for asking in case of problems :wink:

I don’t have a RHEL8 system around for testing, so I can only guess so much.
Double-check your dependencies, meaning that the required packages are installed on the necessary versions.
Also found this: IcingaWeb2 is only in HTML after enabling module businessprocess - Icinga Web 2 - Icinga Community
maybe it helps