Why is my check not working

Hi all,

I am making a new check based on a script I found. The script is an snmp check that looks at the percentage of memory used based on 2 oids. It working nicely when running from icinga backend targeting my host.

This is not the first time I have encountered this problem, it’s not a bug, it’s a way of thinking I am missing.

I created a command based on the shell script and I added arguments:

but the custom properties/arguments never appear in my check that uses that command:


I expected to see the -L, -A etc fields I could fill out in custom properties for the new service template I am making.

Any ideas please?

EDIT: Perhaps the fields appear on the host in director, not the service template in director?

EDIT2: I found this, perhaps I need to create a variable for each “GNU Long Option”?

Hi @Radius540R

you have to add custom vars to the arguments.


‘Arguments’ tab of the command:

Add fields to the command in the ‘Fields’ tab:

The vars then appear in the service that uses the command:

Kind regards

1 Like

Thanks a lot! I am typing in all the vars, not sure i am 100% doing it right as I’m typing it all as custom vars in director, then args in the command, then fields again but so far so good.