Way to Clear pending deployment

icingacli --version
Icinga Web 2 2.11.0
Git Commit 46998464ea9f9e3c2889d98f9fb6df639d972550
PHP Version 7.4.6
director 1.8.1
doc 2.11.0
incubator 0.17.0
ipl v0.5.0
monitoring 2.11.0
reactbundle 0.9.0
translation 2.11.0

  • Icinga 2 version (icinga2 --version): icinga2 - The Icinga 2 network monitoring daemon (version: r2.13.4-1)
  • Operating System and version: openSuse15.3

I am new to Icinga2, and seeking help to clear pending changes.
I think the mistake is to delete the user without removing the dependencies first like, assgined template for that user, and user groups.

So, After deleting the user at first, I can Store other changes but deployment will fail with following API error when clicking Deploy pending changes:

API request failed: Conflicting request, There is already an ongoing package update in progress … (RestApiResponse.php:113)

I have tried to re-deploy the config from the previous week. ( marked in Blue, Oct14th) but same error.

I need help to resolve the problem. Related article : Pending changes in activity log

Thanks A Bunch.

Hi, how long does it typically take to reload icinga2 when running systemctl reload icinga2? Recently, this behavior has been implemented so that you can no longer submit package updates (director deployment) while the previous one is still in progress. Meaning, when the first director deployment succeeds, it will trigger an Icinga2 reload afterwards to apply the new changes, and during this period (while the reload is ongoing), you will not be able to trigger any further deployments.

Thank you for replying back.

time systemctl reload icinga2.service

real 0m9.555s
user 0m0.016s
sys 0m0.008s

I couldn’t remember if it was faster with older release of icinga2.

Apparently, I got this problem of mine resolved by restarting icinga2.service and icinga-director.service.
After restart, i was able to re-deploy the config from the previous week, which created around 57 pending changes in the Activity Log section. After clicking Deploy, director was able to complete package update.