Unable to open reporting module

Hi Experts,

I have successfully

installed and configured the reporting module but when i tried to open the reporting module in icingaweb2 console getting the below error. Kindly help me how to resolve this issue.

SQLSTATE[42S02]: Base table or view not found: 1146 Table ‘reporting.report’ doesn’t exist

Attached screenshot for the reference.

Looks like you may have missed a step during setup:

Hi Ben,

Thanks for the reply.

Yes, I tried the same steps which is mentioned in the documents but still im getting the same error. Also when i go and checked in the database the tables are not created for reporting database. Could you please help me on this. Below are the steps i performed.

  1. went to /etc folder and running the below command
    git clone https://github.com/Icinga/icingaweb2-module-reporting.git reporting
    2.mysql -p -u root reporting < /etc/schema/mysql.sql
    3.After entering above command it’s asking the password and i’m providing the password and after that the folder also created in the /etc directory.

But still facing the same error.

Did i missed any steps. Kindly help me out of this issue.

Pranav R N

I don’t think you’re cloning to the right folder if you’re cloning into /etc/

Shouldn’t matter just for the sql piece though (will matter for the module though).

1.) What’s the output of ls -l /etc/schema/mysql.sql?
2.) What’s the output of mysql -p -u root reporting < /etc/schema/mysql.sql

Hi Ben,

Thanks for the email.

Attached output for the reference.

Hi Ben/all,

The issue has been resolved. My bad i’m trying to importing the schema from different directory so then i executed it from correct directory it went perfect.

Thanks a lot for your help.

Pranav R N

1 Like