Trying to reset password by going through setup, but stuck at /etc/icingaweb2 is not writable

Set up Icinga a while ago but forgot the password, so now I’m trying to reconfigure using
icingacli module enable setup

Problem is almost every step is working in setup, but one;
Read- and writable configuration directory - The directory /etc/icingaweb2 is not writable.

I’ve created a user http who is part of the icingaweb2 group. The permissions on this directory are;
drwxrws— 2 root icingaweb2 4096 Jun 14 22:32 icingaweb2

There’s no selinux running. nginx is running as follows;

ps aux | grep nginx
root 658829 0.0 0.0 12448 2024 ? Ss 22:35 0:00 nginx: master process /usr/bin/nginx -g pid /run/; error_log stderr;
http 658830 0.0 0.0 13160 4716 ? S 22:35 0:00 nginx: worker process

grep icinga /etc/group

The system I’m running is Arch Linux, with a nginx webserver and a postgresql backend.

I’m not entirely sure the page is updating, as the php ldap also wasn’t being detected, so I enabled it in /etc/php.ini, and that’s not changed. php -i shows that ldap is enabled. I’ve tried restarting nginx, but no joy.

Thanks for any help.

Restarting php-fpm solved the ldap issue, but the /etc/icingaweb2 problem remains.

Since php-fpm is the process accessing the directory (nginx is not), the user of that process must be in the icingaweb2 group, if that’s indeed http, I have no other idea right now.

I think the solution is to add this line to this file and restart php-fpm;


ReadWritePaths = /etc/icingaweb2