Timeout exceeded- Terminated by signal 9 - Checker nrpe


I’ve a nrpe based plugin check which run a DB query and takes around 8-15 mins depending on the time of the day. The checker seems killing the “check_nrpe” command after 300 secs. The plugin works fine directly on the client using “icinga” user and while run manually from the checker itself.

This is related to checker and couldn’t find a setting to increase the timeout on it? On the client side, I’ve the “command_timeout” and “connection_timeout” set to 1800.

Please advise.

1 Like

Found it - “check_timeout”