Theme stuck on Winter

Hi everyone,

I’m having a really silly problem. My Icinga web is stuck on the winter theme.

The problem doesn’t occur on the login page but as soon as I’m in Icinga web, the only theme I keep seeing is the Winter one.

Have you ever seen that?

I have restarted icinga multiple time with no success.


I found the solution…

I edited the file /etc/icingaweb2/config.ini and added this under the “themes” section (it was completely empty) :

disabled = “1”

Reconsider that :thinking:

It’s fine that it’s empty. But by setting disabled you’ve made it impossible for users to chose a different theme. That’s also the reason why the winter theme is now gone because you’ve set it as your theme in your account preferences. That setting is now ignored.

Instead of disabling themes entirely you should update your preferences :wink:

I see. I don’t want that!

What do you mean update my preferences?
Maybe I wasn’t clear but I kept changing it in Configuration - Application and it wasn’t doing anything.

Your user has its own configuration page:

Bildschirmfoto von 2020-01-16 16-12-40

Oh I see that now…

then what is the point of the one in Configuration - Application?

There you can set a default, that is used for everyone, unless they change it for their own account themselves.
This default will be used at least once when some logs in for the first time.

@log1c I get it. Thank you very much!