The url must not be external

Any idea what’s the problem here? I try to add the tactical view to the dashboard.
Did not modify the fields.

1 Like

Did you try to set the whole fqdn into the url section like explain here Dashlet external URL · Issue #3234 · Icinga/icingaweb2 · GitHub ?

Hi DocMax & all,

I’m getting the same error message with url “icingadb/tactical”

icingaweb2 version 2.11.3
(Trying to add a dashlet from an icingaweb2 module on the same host to a new or existing dashboard.)

I guess “external” in this context would mean stemming from a different FQDN or server entirely?
Maybe someone has an idea how to further diagnose or workaround that… :slight_smile:

Happy new year,
Barney

I have the same problem. I use Icinga in Docker since a few days. I can’t add new dashboard or modify the existing one.

Hi guys, I made it. Please try it out for yourself. Select in menu the Overview/Tactical Overview. Then copy the full url (e.g.: http://localhost:8080/icingadb/tactical) and paste it in the url box at Add Dashlet.

Hi guys, another solution: create a folder under the icingaweb configuration directory with the name “dashboards”, and a subfolder with your full username (e.g. XY@local). Then create a “dashboard.ini” file under it with the following content:

[Hosts & Services]
title = “Hosts & Services”

[Hosts & Services.Overview]
url = “icingadb/tactical”
title = “Overview”

Also tried full URL and any kind of variations - no chance!

I allready have such a dashboard.ini file

[Current Incidents]
title = “Current Incidents”
disabled = “0”

[Current Incidents.Tactical Overview]
url = “monitoring/tactical”
title = “Tactical Overview”

[Overdue]
title = “Overdue”
disabled = “0”

[Muted]
title = “Muted”
disabled = “0”

The url is wrong, new-dashlet → tactical
http://icinga.intra/monitoring/tactical

It means, you have the Tactical Overview under Current Incident dashboard?

Yes, but whatever i have currently it does not matter. For ANYTHING i want to add i get that external link error.

Can you please send a screenshot where I can see the url too what do you use to icingaweb?
Do you use it in Docker (or in some other type of container)?
You can add the dashboard via the INI file, it should be defined (e.g.: all host), just add the following lines:

[Example Dashboard]
title = “Example Dashboard”

[Example Dashboard.Example Dashlet]
url=“monitoring/hosts”
title = “Example Dashlets”

Dashboard

Looks like, that this comes with the latest update(s)?

If I copy and paste my links from my old dashboard like “icingadb/hosts…” into a new dashboard, I also get this error message.

The old dashboard is still working. Bit confusing…

1 Like

Modification directly from the dashboard.ini on the server seems working as expected
/etc/icingaweb2/dashboards/myuser/dashboard.ini

1 Like

Same issue here. My setup is running in podman containers, but that should not matter.

It should still work from the dashboard.ini file.
I’m running it in the Docker container. It works for me on the icingawebsite with the following workaround:
http[s]://[ip or name]:[container port]/[query]
So for me protocol http, name icingaweb, port 8080 (it’s published on a different port (80), but the container itself listens on 8080), query icingadb/hosts. So if I want to create a new dashboard, I should enter the following for the URL: http://icingaweb:8080/icingadb/hosts

Yes, manual editing the config file works. However, I got people on my team that are not comfortable working directly with the container.

So, it would be nice if this gets fixed :slight_smile:

Question btw: is there a possibility to store dashboards for a group instead per-user?

You can share a dashboard. I never used or tested it…

https://icinga.com/blog/2020/06/11/current-state-of-development-dashboards/

https://community.icinga.com/t/global-dashlets-available/1209

Looks like there will be a fix (of some sort) with the next release :slight_smile:

Maybe try applying it manually and see if it helps.

1 Like

Hello, this information is outdated! But here is the development branch. It doesn’t have dashboard sharing support yet, but if you want you can test it in a demo.