[Solved: IE to blame] Module Cube featuring No Cubes

I decided to try the Cube module, installation went without a hitch, I enabled it and now under “Reporting” I can select custom variables and slice but I don’t see any of the cubes shown in the documentation.

All I can do is keep adding dimensions and Cube lets me on the right pane to “Show hosts status” and “Modify XX hosts” but I can’t see no cube at all. What am I missing? Is there any log I can check or debug switch to toggle?

I’m running CentOS 8 and the DB is MySQL 8.0.17

Icinga versions as follows:


My bad, I was using our default browser IE 11 and didn’t dawn on me that I could check with a real browser. Cubes are shown in Chrome.


1 Like

:rofl: :rofl: :rofl:

That was very nicely put!

As far as I know, it should work in IE11 though, so I’ll bump that over to our devs anyway. At least I think we do, and if we don’t I’ll find out :smiley:
Thank you for noticing!

Also, the way we mark topics as solved is by selecting an answer as the “solution” - in this case that would be your own :slight_smile:
So feel free to just pop that solution on yourself :slight_smile:

Have a nice day!

1 Like

So, a little update on this issue (in case you are interested):

We are indeed still supporting IE11, but in this case it looks like the tradeoff of setting a dev on it for a day - for a browser that barely anyone uses - dimms the priority a little…
Would maybe be a good task for one of our trainees in the future, but that might take a while.

But since you seem to be able to circumferent the issue with a different browser, I feel like that’s an alright way to deal with it :slight_smile:

Have a nice day!

Thank you @theFeu for going the extra mile, IE11 support is not a big deal to me in the end. After playing with the Cube for a bit I got a couple questions about the information displayed. If I cannot figure it out myself I will let everybody know. :smiley:

That’s the spirit!

Well, have fun tinkering with it and see you in another topic maybe!