[Solved] Director Notification - MS Teams Webhook

Hey All,

Running into an issue trying to get notifications to work from Director in MS Teams. I am using the scripts created by @unic NeverUsedID/icinga2-msteams: Icinga2 notifications for MS teams (github.com) and when I run the script from the terminal using my channels webbook with the -p switch I get the expected results and a blank post to the channel.

However after my set-up in director, when I try to submit a Custom Notification, nothing is posted to the channel.

Below is my set-up if anyone can Identify where I am going wrong that would be a great help!

Time Periods

User Templates


Notification Templates

Notification Objects


Software Versions

  • Director version: 1.8.0
  • Icinga Web 2 version: 2.8.2
  • Icinga 2 version: 2.12.3
  • Operating System and version: RHEL 8.3
  • PHP version: 7.2.24

Hi !

Notification events are shown in the Icinga logfile is the notification triggered there ?
Or does not trigger event happen at all ?



Hey David,

When will I learn the Logs are always the best place to start :upside_down_face:

Looks like a permissions issue with the script

[2021-07-28 12:06:04 +0100] warning/PluginNotificationTask: Notification command for object 'hostname' (PID: 3342667, arguments: '/etc/icinga2/scripts/teams-host-notification.pl' '-4' 'IP '-6' '' '-b' 'username' '-c' 'Test' '-d' '2021-07-28 12:06:04 +0100' '-l' 'hostname' '-n' 'hostname' '-o' 'PING OK - Packet loss = 0%, RTA = 38.04 ms' '-p' 'https://xxxx.webhook.office.com/webhookb2/xxxxx/IncomingWebhook/xxxx' '-s' 'UP' '-t' 'CUSTOM') terminated with exit code 128, output: execvpe(/etc/icinga2/scripts/teams-host-notification.pl) failed: Permission denied

Edited the permissions of the script and now all is working. Thanks for your help!