SNMP OID ,SNMP NET , SNMP AGENt, trap director

I have configured trap director , edit the trap handler along with cisco interface MIBS but not able to receive any trap
I am newbie and while configuring I might be missing some step while configuration
it would be grateful if some one respond on urgent basis.

Hi,

  • Is the director installed correctly ? It should show a single green status bar reading “All tests OK : DB, IdoDB, API, snmptrapd”.

  • Is the service “snmptrapd” running ? You can check with “systemctl status snmptrapd.service” and “ps -f -C snmptrapd”

  • Is your device actually sending traps ? You can check with a MIB Browser

More information on your setup would be helpful. :wave:

Looks like your service is not running or got stopped. What does the trap director configuration say ? You can find it under Configuration → Modules → Trapdirector → Configuration

Edit: Did you remove the path pointing at the location of the snmptrapd.pid ? There should be one after your start options.

You could try adding the -n option to the start options and any other option the configuration interface asks for. Consider censoring your IP Address also ? :face_with_raised_eyebrow:

Actually , I want to add HOST that should be on snmp and send traps in trapdirector, All configuration is done but still facing issues in snmptrapd has no -n option.
I attached Screen shots and I did not understand what is exact problem.
If any body can share step by step manual it would be really nice.

Did you also reload the service with the new config file ? You can do so with:

systemctl disable snmptrapd
systemctl daemon-reload
systemctl enable snmptrapd
systemctl restart snmptrapd


Every thing is working fine, but still trap are not receiving.I attached Screen shots and I did not understand what is exact problem.
If any body can share step by step manual it would be really nice.