SNMP Issue

Hi All,

I’ve got an odd problem when attempting to template SNMP in Icinga Director. I have setup the required data fields and lists, applied them to a template, applied to the host, with the correct information filled in. However when the check executes I am met with the error:


This is where I’m confused. I’ve got two fields currently, one called ‘authpasswd (which stars out the password in the gui)’ and one named ‘snmpv3_auth’. Neither of these fields appear to be taken by the module as the authpasswd.

Any ideas as to why the snmpv3 module is ignoring these fields? Any help greatly appreciated.


Can you please post the whole command line that is executed by the check (see the “Inspect” link in the service overview page)?
This way we can see what check script you are using and you/we can see what arguments are appended to the script via the variable fields.

Hi log1c,

Sorry for the delay, I had to update director. Here’s the running command:

'/usr/lib/nagios/plugins/check_snmp' '-A' '69616F4A45056E00A2D37CB1F6F1643FAE7D05B5167439ECB62EA58B454D1FC417FA4DE889DCF24F1175AF7354D6968297423D93BB714C2BD80D748BAE7F2075' '-H' '' '-L' 'authNoPriv' '-P' '3' '-U' 'USER' '-a' 'SHA' '-o' '' '-t' '10' '-x' 'AES'

Now I can instantly see issues here. It’s attempting to use SHA, and also appears to be adding the privacy authentication used in authPriv. I have MD5 and authNoPriv in my Icinga configuration…

Any ideas why it’s adding these extras despite not being present in the service configuration on the host?

check /icingaweb2/director/commands?type=external_object&q=snmp#!/icingaweb2/director/command/render?name=snmpv3 and take a look at the pre-defined command and its arguments. You will see that the imported command from the ITL already defines some default values.
Check if you have defined all the needed fields for the snmpv3 authentication.

1 Like

log1c, your a diamond.

Turns out I had a few of my data fields incorrectly mapped and that was throwing the snmpv3 command out. Thank you for pointing me in the right direction there, greatly appreciated!

1 Like

No problem, happy I could help :slight_smile:

Please flag one answer as a solution, so the thread gets marked “solved” :slight_smile: