Remote Icinga instance is not connected

we are running our icinga2 server on a vm. In the past month the server shows a strange behavior:
Some clients are showing “client not connected”. After some time the message disappears and some
other clients are shown to be not connected. A restart of the server is forcing this behavior.

After some checks we so the following error in the log file:
[2023-04-14 10:58:45 +0000] warning/JsonRpcConnection: Error while sending JSON-RPC message for identity ‘xxxx’
Error: Broken pipe

0# __cxa_throw in /usr/lib/x86_64-linux-gnu/icinga2/sbin/icinga2
1# 0x000056530D3B2CFF in /usr/lib/x86_64-linux-gnu/icinga2/sbin/icinga2
2# icinga::NetString::WriteStringToStream(boost::intrusive_ptr<icinga::Sharedicinga::AsioTlsStream > const&, icinga::String const&, boost::asio::basic_yield_context<boost::asio::executor_binder<void ()(), boost::asio::executor> >) in /usr/lib/x86_64-linux-gnu/icinga2/sbin/icinga2
3# icinga::JsonRpcConnection::WriteOutgoingMessages(boost::asio::basic_yield_context<boost::asio::executor_binder<void (
)(), boost::asio::executor> >) in /usr/lib/x86_64-linux-gnu/icinga2/sbin/icinga2
4# 0x000056530D674D66 in /usr/lib/x86_64-linux-gnu/icinga2/sbin/icinga2
5# 0x000056530D6B1894 in /usr/lib/x86_64-linux-gnu/icinga2/sbin/icinga2
6# make_fcontext in /lib/x86_64-linux-gnu/

Our server is running Ubuntu 22.04 LTS
Icinga 2.13.7-1+ubuntu22.04

Any idea what might cause the trouble ?
Bye Peer

Blind guess, you are using unsupported version combination are described here.

Thanks for the hint. We will check it.
However the master “should” - we have to check - be the newest release.
Bye, Peer

So I stopped a couple of old clients - without success. For me it looks like this issue

I’m pretty sure that older releases of icinga worked - has anybody tried to downgrade the packages ?
In the moment we have installed:
ii icinga2 2.13.7-1+ubuntu22.04 amd64 host and network monitoring system
ii icinga2-bin 2.13.7-1+ubuntu22.04 amd64 host and network monitoring system - daemon
ii icinga2-common 2.13.7-1+ubuntu22.04 all host and network monitoring system - common files

2:13.3 (or 4) did not show the behavior (pretty sure). Maybe I try it later …