Remote Icinga instance is not connected to Icinga Master

Hello all you smart Icinga people. I’m an Icinga noob, so please go easy on me.

I have recently deployed Icinga2 (r2.11.2-1), Icinga2 Web (v2.7.3), and Director (v1.7.1) on a Ubuntu 19.10 system. I have setup Service Templates, Service Sets, and Host Templates in Director. I have installed the Windows 2.11.2 agent from http://packages.icinga.com on a Windows 10 client and followed all the directions for installing the agent and running the PowerShell kickstart script I downloaded from Director using the Agent Setup on Windows: Installer instructions. Firewall has been disabled on both Windows and Ubuntu to rule out blocked communication. All health checks pass/green.

In Icinga Web, the hostalive and ping4 are the only services that are showing as UP, all other services reflect a Remote Icinga instance '<client.hostname.fqdn> is not connected to '<icinga.hostname>' (actual hostnames removed) error message.

I have been trying to read and re-read all the install and deployment guides, but at this point I’m lost. I could really use some assistance to help me get my first host monitored.

Hi & welcome to the icinga community,

my blind guess: your certificates are not signed. Details can be found here.

1 Like

You were right, the certificates weren’t signed. Regardless, I have signed them now, but the same issue remains. There were three certificates listed for the same client. I’m assuming this is because I uninstalled and reinstalled the agent a few times during my troubleshooting process. My guess is that the latest certificate is the current one, but to be safe I signed all of them. And I wasn’t sure if I needed to restart the icinga2 service, but I did for good measure.

After signing no restart is required. Since your are still experiencing the same issue, I’d blame your config to be invalid. For agents the hostname in the director, zonename and certificate cn have to be identical.

If there is something else wrong, I’d recommend to check the logs.

When using Director, are you still supposed to run the command icinga2 node wizard?

If yes, when running the wizard, there’s a question that asks Do you want to disable the inclusion of the conf.d directory [Y/n]:. What is the correct response to prevent any conflicts with Director?

Still trying to troubleshoot this agent connectivity issue.

Yes. And this should always be the first step, even before start configuring the director (in my opinion).

conf.d contains examples be default and they shows how to use conf files. For using the director it’s recommended to not mix it up with such conf files. Hence, it’s recommended to disable inclusion of conf.d.

1 Like

Ok, I performed a clean install of Icinga2 with Director, then I ran icinga2 node wizard making sure to select Do you want to disable the inclusion of the conf.d directory [Y/n]: Y. After that I configured Service Templates, Service Sets, and Host Templates successfully, but when I added the host I received the following error. What does this mean? How do I get past this error?

I figured it out. In zones.conf I had to rename this piece of code

object Zone “master” {
endpoints = [ “MasterHostname.fqdn” ]
}

…to this:

object Zone “MasterHostname” {
endpoints = [ “MasterHostname.fqdn” ]
}

Everything is working properly now, except for an NSClient++ check, which I still need to investigate. Many thanks for your assistance in helping me to resolve this issue. Cheers.