Remote Icinga instance '' is not connected to ''

Hi, guys,

I know, the subject has come up at one time or another, but unfortunately the steps suggested there could not help me much.

For my final project I am currently setting up an Icinga server (version r2.8.1-1) on an Ubuntu 18.04.04 LTS.

In our company we only use Windows machines, on which I have rolled out all important Powershell scripts that are executed via a custom command.

Now it unfortunately only fails because of the connection to the agent. I installed the Icinga2 Agent on the client machine and signed the certificate on the master side. In the zones I defined the host as the “master” of the client and really checked if the same FQDN was used everywhere.

One thing still confuses me though. I find only the certificate of the master under /var/lib/icinga2/certs/, but not the certificate of the client( Although the certificate of the client is signed under “icinga2 ca list”.
This is the relevant extract of the log files for this:

[2020-05-11 00:09:51 +0200] critical/GraphiteWriter: Exception during Graphite operation: Verify that your backend is operational!
[2020-05-11 00:09:53 +0200] information/ApiListener: New client connection for identity ‘MUE-ILP-SRV-11.ILP.NET’ from []:61164 (certificate validation failed: code 18$
[2020-05-11 00:09:53 +0200]

If you need more information, please do not hesitate to ask
Many greetings

Hi and welcome :slight_smile: ,

what’s the icinga2 agent version on your windows clients?

r2.8.1-1 is really out of date (~2 years).
Seems like you are not using the official packages from Icinga2 itself. Take a look here how to setup the repository for ubunut.


Hello :slight_smile: ,
For the Windows Agent I just use the latest icinga Snapshot (from 04/27/2020). Do you recommend upgrading my Icinga Server to the latest version?

Many greetings


could be worth a try as the master should be on a higher or same version as the agents (doc ref).
For upgrading don’t miss the upgrading docs.


warning: keep in mind that only one version between agent and it’s parent node is supported.

E.g. master 2.11 --> satellite 2.10 --> agent 2.9

1 Like

Hello guys once again,

Before upgrading, I tried following the exact same steps as before on another host and it worked like a charm without any errors. Maybe i made a stupid mistake regarding FQDN’s, but the error is gone for now.

Thank you all nontheless for your help

Hope you all have a good day

Hey there!
Did that solve the issues on the original problem host as well?
Please excuse the nosiness, but I am always super suspicious, when errors just …disappear :thinking:
At least when it comes to our own software :smiley:
You have a good day as well!