Relation icingaweb_user_preference missing?

Hello everybody,

we have our current Icinga installation in productive use for around 5 months by now, and avoided creating more than one admin-user for Icingaweb2 until now since we are using alternative frontends for Icinga. The new user just tried to change his preferences (timezones etc.) and got a stacktrace that the relation icingaweb_user_preference is missing. I checked this in the backend and it is missing in fact. Is there anything I can do to create this relation retrospectively?

Regards
Daniel

Hi,

which version of Icinga Web 2 are you using? Also, please show the tables available in your database backend, e.g. with mysql icingaweb2 -e 'show tables;'.

Cheers,
Michael

I am using Icingaweb2 v2.7.1 with php v7.1.30.

\dt in PostgreSQL for my icingaweb-database shows:

Schema | Name | Type | Owner
--------±---------------------------±------±----------------
public | icingaweb_group | table | icingawebdbuser
public | icingaweb_group_membership | table | icingawebdbuser
public | icingaweb_user | table | icingawebdbuser
(3 rows)

I hope this is what you were asking for :slight_smile:

Cheers.
Daniel

Seems that the import of the schema initially went wrong. I’d say you can just re-run all the 3 statements inside the schema here: https://github.com/Icinga/icingaweb2/blob/master/etc/schema/pgsql.schema.sql#L79

Cheers,
Michael

Thank you very much for the heads up, I will try this and close the thread as soon as I am having access to the environment again.

Sorry for the belated reply. Your solution worked like a charm, thank you very much.

1 Like

No worries, we are all people with a day job and often other things delay answers. Thanks for coming back :+1: