Problem with notification interval (cause might be check interval?)

Hello Icinga2 community!

Until a few weeks ago we still used Icinga1 which was ported to a self written html page. But since that has gotten, erm, a bit old by now, we are currently in the process of switching over to Icinga2.

Most of the work was done by a colleague of mine who has left the company around 2 weeks ago. While Icinga2 in and of itself is working, there are some smaller problems which I couldn’t solve so far (it doesn’t help that I am bit overwhelmed at the moment). As far as I know, he has implemented everything using only the Icinga2 Web GUI (so the director basically) and hasn’t really done anything on the machine itself. So of course I am trying to fix those “bugs” also using the Icinga2 Director.

The Icinga Web 2 version we are using is 2.8.2 and the director is in version 1.8.0. I basically have 2 problems, both regarding notifications.

First of all:
E-Mails are send every 5 minutes, which is the check interval on this particular service, instead of whatever I am writing in the Notification interval. Currently there is 600 seconds as the notification interval, yet I am still receiving mails every 5 minutes, so on every check of the service.
On another service I changed the notification interval to 60 seconds as well as the check interval and there I do get it every 60 seconds. But only after I actually changed the check interval.
Services are checked for: Flapping Start, Flapping Stopped, Custom, Problem and Recovery

It is checked if the host/service has notifications enabled and if it is part of a specific group (since some are only sending Mail, some are sending SMS, some are sending both, etc.).

…and looking at it now, it seems my colleague never checked any state. So that’s empty.

Second problem:
Basically the same but with sending a SMS to our phones. Here it seems to be stuck at 15 minutes no matter what I change. However, I have to admit that I am not completely sure if this is the fault of Icinga2 or of our SMS-Gateway we are using. We did manage to get a delay in sending the SMS (2 minutes after the mail at the moment) but then… yeah, every 15 minutes.

So yeah, that’s it. Could be a completley stupid non issues because I just lack experience with the program or because my colleague forgot something. Thanks in advance for any reply!

I am just guessing here, but I think your colleague may have set volatile to true, which would be explaining a notification with every check as it tells Icinga 2 to handle every change of the output as a state change.

As the problem is very abstract without the configuration, you can navigate to the preview tab of an object in the Director and share this configuration or even go to Deployments and then to the Config tab of it where you can see the complete configuration like if it was written in file format.

1 Like

I saw that volatile function mentioned in another thread and I assume it may be the same here.

Well, here is the preview of said service. It’s pretty short but I think I am at the right place (Director → Services → Single Service → Select the Service → Preview - I am using the german version, so I hope my translation is correct):

object Service “Zeiterfassung” {
host_name = “xbet-w7”
import “ageneric-snmp-process”

vars.snmp_process_name = "scttcs.exe"


Oh wait, you probably want the full version:

object Service “Zeiterfassung” {
host_name = “xbet-w7”
check_command = “snmp-process”
max_check_attempts = “4”
check_period = “24x7”
check_interval = 5m
retry_interval = 40s
enable_notifications = true
enable_active_checks = true
enable_passive_checks = false
enable_event_handler = false
enable_flapping = true
enable_perfdata = true
try { // This setting is only available in Icinga >= 2.8.0
flapping_threshold_high = 95
} except { globals.directorWarnOnceForThresholds() }
try { // This setting is only available in Icinga >= 2.8.0
flapping_threshold_low = 93
} except { globals.directorWarnOnceForThresholds() }
volatile = true
vars.Benachrichtigungen = [ “DBMG-Wartung” ]
vars.snmp_process_name = “scttcs.exe”

Edit 2:
So yeah, volatile is active. Where exactly would I change that setting?

It should not be enabled by default (and I think also flapping should not), so move up the Template hierarchy until you see in the Check execution section Volatile set to Yes and change it to No (and the same for Flapping).

Ah, found it, thanks.
I am pretty sure flapping is activated because that’s how our Icinga1 is working. Since we basically copied all services and tried to get them as close to behave as they do at the moment we also activated flapping.

Not sure why he activated volatile though. As far as I know, Icinga1 doesn’t have something similar.