Problem with multiple arguments in nscp_api check

Hi!
I’m struggling with an nscp_api check.
I need to add multiple values in the argument. In my case the would be processes running.

If i run the ceck in cli all is fine:
‘/usr/lib64/nagios/plugins/check_nscp_api’ ‘–password’ ‘asdf’ ‘-H’ ‘x.x.x.x’ ‘-P’ ‘5668’ ‘-a’ “process=macmnsvc.exe” “process=masvc.exe” “process=mfemactl.exe”

If i configure this in director, there are additional ticks around the arguments behind ‘-a’:
“process=macmnsvc.exe” “process=masvc.exe” “process=mfemactl.exe”'

…and the check fails.

I also tried to define the arguments as array: [“process=macmnsvc.exe”,“process=masvc.exe”], but the error is the same:

Plugin Output

check_process Invalid command line: unrecognised option ‘[“process=macmnsvc.exe”,“process=masvc.exe”]’

How can i get rid of them? Or is there an other solution for my problem?

Thanks in advance!

Configuring the datafield for the arguments as an Array type should solve this.
This is likely similar to the nrpe_arguments datafield: Check Drive Size - #4 by log1c

If this indeed does not help please provide more information on how the check is configured, e.g. with screenshots from the Director.
Do you, be chance, have the " in the check definition?

1 Like

Thanks for the hint, i solved it that way :slight_smile: