Problem with GRAPH after update to GRAFANA 7.0

HI All!
Today I have updated the server where I have installed ICINGA and GRAFANA.
Grafana was Updated to ver. 7.0
After this update I noticed problem with the GRAPH into ICINGA web interface:

Anybody have experience of this kind of error?
How can be solved ?
The IMAGE is linkable and link works fine.
The problem is the render of graph inside web interface of icinga


It has been mentioned here a couple of times but there have been big changes in Grafana 7.
Read the blog or the relevant release notes.


1 Like

Thx for answer.
Is not clear for me if we need to modify something into ICINGA config…
We need to install the plugin on ICINGA server ?

Depends on how you run Grafana in your environment.
If you have a normal installation, you need to install the plugin in Grafana itself.
If you run it in docker, you need an extra container as described in the blog post.

No changes required in Icinga afaik.


Look at here: FYI: Grafana upgrade (v6 to v7) breaks grafana integration with icingaweb2

I run ICINGA and GRAFANA right now, on the same server.

Symply I have instaled the new plugin into my Grafana Server as described here:

Everything seems to works fine, now

Try install “libXScrnSaver”
Example for CentOS8:
dnf -y install libXScrnSaver