Plugin Output: Command "C:\Program Files\ICINGA2\/sbin/check_snmp" -C public -H *IP address here* -t 10 failed to execute: 2, "The system cannot find the file specified."

Hi there,

I am new to the Icinga community, so please take it easy on me!

I am currently trying to set up the monitoring of devices via SNMP.
The host appears to have connected and is communicating with the Icinga server, but I am getting the below service problems:

Any help or a push to the right direction would be greatly appreciated, thanks!

There is simply no check_snmp on the Windows system.

Typically you want to execute check_snmp on the master or satellite so without setting the command_endpoint (in file-based configuration) or execute on agent (in Director).

Thank you for the reply, Dirk.

How would I go about executing check_snmp on the master or satellite?
Would this be through the “Commands” tab in Director?

You need to change the following option in your service template, that is used by the check “check-snmp” to “No”

This will switch as execution of the check from the client on the agent to the master/satellite.

Run on agent = yes should nly be used if the check has to be executed locally on the host it is applied to.