Ping says server is down but other checks work


I have a lot of servers setup and all works fine and well, except for one I added a few days ago. All checks work fine, except the standard host service check that icinga does to see if the host is down. I have already set the Check execution time to 30.0004s because it was behaving like this with some other servers as well, and upping the check time helped. But 30s is a bit long anyway, and this server is nothing special, there is no reason why it should take this long for it to timeout.

Only thing I can see is that it times out, there has to be some other solution than to again up the time for the check, or…?


If your using icinga as agents, you could use cluster-zone instead of hostalive.

1 Like

Depending on the host it might not accept pings/icmp packets by default.

If Windows: check the local windows firewall to allow icmp echo requests.
linux hosts could have something like iptables, firewalld that block the icmp requests.
Network devices sometimes drop icmp packets as well.

A firewall between the monitoring server and the host can also be the reason.

Rolands tip for using the check for the agent connection (if the Icinga agent is used) is also an option. This way you would also have the feedback if the host is connected to its parent as well.

This was the solution for solving my problems! Thank you so much for that very good hint!
I spend weeks of investigation into icinga but i always failed by Host Down Timeout exceeded.
But after i created a service template and also services like hostalive i saw that they are running perfectly on my remote windows client! So that means that my installation/configuration was always fine! The only issue was the hostalive command in host template that doesnt work and that fooled me crazy!
If you set hostalive as check command in the Host template the master tried always ping themself.
So this saved my evening! Many thanks! :slight_smile: