PHP-FPM Failure

i have get an error in the icinga2 director. Anybody know this problem?

This error comes if i select a host in icinga director. In the services tab i select not a single service, rather a service, which is part of a service-set and bound to a hostgroup.

In the director gui i get the following error messages:

Uncaught Error: Call to undefined method Icinga\Module\Director\Resolver\OverriddenVarsResolver::resolveFor() in /usr/share/icingaweb2/modules/director/library/Director/Objects/DirectorDatafield.php:260
Stack trace:
#0 /usr/share/icingaweb2/modules/director/library/Director/Objects/DirectorDatafield.php(240): Icinga\Module\Director\Objects\DirectorDatafield->applyObjectData(Object(Icinga\Module\Director\Web\Form\Element\Text), Object(Icinga\Module\Director\Forms\IcingaServiceForm))
#1 /usr/share/icingaweb2/modules/director/library/Director/Web/Form/IcingaObjectFieldLoader.php(380): Icinga\Module\Director\Objects\DirectorDatafield->getFormElement(Object(Icinga\Module\Director\Forms\IcingaServiceForm))
#2 /usr/share/icingaweb2/modules/director/library/Director/Web/Form/IcingaObjectFieldLoader.php(183): Icinga\Module\Director\Web\Form\IcingaObjectFieldLoader->createElements(Object(Icinga\Module\Director\Forms\IcingaServiceForm))
#3 /usr/share/icingaweb2/modules/director/library/Director/Web/Form/IcingaObjectFiel

#0 [internal function]: Icinga\Application\Web->Icinga\Application\{closure}()
#1 {main}     

It seems to be an error with php-fpm(systemctl status php-fpm).

journalctl -u php-fpm
Jan 28 14:19:45 HOSTNAME icingaweb2[248257]: ErrorException in /usr/share/icingaweb2/modules/director/library/Director/Objects/DirectorDatafield.php:260 with message: Uncaught Error: Call to undefined method>

  • Icinga Web 2 version 2.8.2
  • Business Process 2.3.0
  • FileShipper 1.2.0
  • Grafana 1.3.6
  • Incubator 0.6.0
  • IPL 0.5.0
  • Map 1.1.0
  • MapDataType 0.1.0
  • Nagvis 1.1.1
  • Reactbundle 0.8.0
  • Reporting 0.10.0
  • x509 1.0.0
  • Chrome 81.0.x
  • Icinga 2 2.12.3
  • PHP 7.2.24
  • CentOS 8.3.2011



I have the same error, but nothing in FPM log.

Error occurs when I want to edit a service connected to a host using apply policies.

Are there any updates on how to fix that?

Hello and welcome to the community you two,

if you think you found a bug, please feel free to open an issue on GitHub, as that is where the developers are the most active and where our bug reports go. :slight_smile:



I now figured out that I was on master branch. Only there the error seems to occure.

I deleted /usr/share/icingaweb2/modules/director and cloned stable version v1.8.0.

Now it works for me.

Delete current director

rm -R /usr/share/icingaweb2/modules/director

Reinstall Version 1.8.0

REPO_URL=β€œGitHub - Icinga/icingaweb2-module-director: The Director aims to be your new favourite Icinga config deployment tool. Director is designed for those who want to automate their configuration deployment and those who want to grant their β€œpoint & click” users easy access to the configuration.”
git clone β€œ${REPO_URL}” β€œ${TARGET_DIR}” --branch v${MODULE_VERSION}

1 Like

It works also for me. Thanks for the informations!