Nscp-local-uptime (WARN/CRIT) not accepted?

Trying to set the warn=none and crit=none for nscp-local-uptime, however icinga doesn’t seem to honor both settings at the same time… Is there something I am missing in the syntax?

apply Service "System Uptime" {
    import "service-check-alarm-settings"
    check_command = "nscp-local-uptime"
    command_endpoint = host.vars.client_endpoint
    enable_notifications = false
    vars.nscp_arguments = "crit=none warn=none"
    vars.grafana_graph_disable = true
    vars.nscp_showall = true
    assign where host.vars.client_endpoint && host.vars.os == "windows"
}

This is when I have:

vars.nscp_arguments = "crit=none warn=none"
image

This looks similar to the error above

I can make this work fine using the nscp.exe client xxxxx
image

I’ve tried the following:
vars.nscp_arguments = "crit=none warn=none"
vars.nscp_arguments = "crit=none and warn=none"
vars.nscp_arguments = "crit=none --warn=none"
vars.nscp_arguments = "'crit=none warn=none'"
vars.nscp_arguments = "--crit=none --warn=none"
vars.nscp_arguments = "crit=none, warn=none"

…None of these work… just shooting in the dark now, hoping something knows the answer?

If I used just
vars.nscp_arguments = "crit=none"
or
vars.nscp_arguments = "warn=none"

Then I get at least 1 to work… but then I am stuck with either a CRIT or WARN condition.

Also, this is from a icinga2 object list --name nscp-local-uptime
Per the output, the argument option places “–” in front, so having “crit=none warn=none” I would think that translates into “–crit none warn=none” ???

checking to see if anyone has some info on this ?