No services found matching the filter

Hi,

I’m completely new to Icinga2 and setting up this kind of stuff. I’m going to monitor some internal network devices and followed through the guides listed on https://icinga.com/docs for Icinga 2 and Icinga Web 2.

I installed everything on an Ubuntu server in the backend with MYSQL, Apache2 and Icinga2.

When I first started up the GUI through login on the web, it showed me some stats like SSH and HTTP from the server where the application is running (iguess from a default template the SSH and HTTP showed up).

After following this guide for setting up master, the issue seems to have come: https://medium.com/@robinjohnobrien/icinga-2-master-node-part-4-97014192b10

By restarting the icinga2 service and server, the error occurred:

“No services found matching the filter.”

comes up in every page listed on the website.

I tried adding a host just to test if it would show up, but it didn’t help.

Tried the following:

systemctl restart icinga2.service | Active (running)
systemctl restart icinga2 | Active (running)
icinga2 daemon -C
icinga2 node wizard

user@server:~$ sudo icinga2 node setup
critical/cli: You need to specify at least one endpoint (–endpoint).

Is this the issue perhaps listed above?

Some assistance would be nice :smiley:
Thanks in advance!

Br
Magne

Hallo @Networkmagne, welcome to Icinga Community and nice to see you using Icinga. During the Icinga2 node wizard you may have pressed yes to disable the inclusion.
Do you want to disable the inclusion of the conf.d directory [Y/n]:

Here you can read it in detail and also perform master setup with the help of the official documentation. Everything is explained step by step, what exactly the node wizard questions mean.

EDIT:
If you don’t want to run Icinga2 node wizard again, you can uncomment the following part include_recursive "conf.d" and remove the including of conf.d/api-users.conf in /etc/icinga2/icinga2.conf file.

**
 * Although in theory you could define all your objects in this file
 * the preferred way is to create separate directories and files in the conf.d
 * directory. Each of these files must have the file extension ".conf".
 */
// Disabled by the node setup CLI command on 2020-11-01 18:52:25 +0100
//include_recursive "conf.d"
// Added by the node setup CLI command on 2020-11-01 18:52:25 +0100
include "conf.d/api-users.conf"

Best,
Yonas

Hi @yhabteab

It was indeed the master setup.
I managed to get it done with running the Wizard again, and not disabling conf.d :slight_smile:

For that, I also managed to get the network equipment monitoring up and running in the dashboard.

I’ve now turned off the Ubuntu server, and re-installed to a CentOS server in production, and sat it up again. Everything seems to be working just fine now from my side. :smiley:

I’m currently trying to fix the monitoring so I get notified when the hostalive’s are down.

Thanks for your assistance.

1 Like