No email notifications received


i have problems setting up icinga2 mail notifications, maybe someone could give me advice?

i don’t really have enough experience in such things, sorry, i’m just a beginner… i had a look at the documentation, tutorials and questions previously asked about similar problems, but i don’t know what exactly my problem is.

i checked the templates.conf, users.conf, notifications. conf and hosts.conf files, it’s all set up by default and it looks like the instructions suggest. i set up a gmail email account with less secure apps enabled and added the mail address in users.conf. the notification feature is enabled.

in the gui, it says, “1 notification has been sent for this issue” for a host that’s down, but i didnt receive any mails.

if i run /etc/icinga2/scripts# ./, it says:
mail not found in $PATH. Consider installing it. , and i suppose this indicates the problem, still i don’t know what to do now.

i got told that i can just tell icinga2 the mail address and that’s it, that i don’t need a mail server, is that correct?

i’d be thankful for any advice!


You would need your system setup with a postfix relay so that the mail command could send email first. This can be done with gmail accounts, but requires some work outside the realm of Icinga.

What Linux distribution is your master running on? A quick google and I found guides for debian and ubuntu,


hi Blake, thanks for Your answer. This is what I needed!

Unfortunately, I made a mistake setting that up and now i can’t access the icinga2 web interface anymore. i’d like to ask for advice again, even though it’s probably not that icinga specific…

i removed (purged) the packages libsasl2-2:amd64, libsasl2-2:modules:amd64 and libsasl2-2:modules-db:amd64 because something didn’t work out with authentification. I had installed libsasl2-modules as the guide says.

i guess i destroyed something, i reinstalled those three packages but i can’t access icingaweb2 in my browser.

so, does anyone have an idea how to fix this? I hope there is a way other than reinstalling the icinga2 server over again :frowning:

1 Like

it seems like i cant undo it, so i’ve decided to newly setup the monitoring server. i’ll try setting up the relay host again then. thanks for the advice!


Hello there!
Sorry to hear about the botched server, I hope it works out this time around!

If the answer you got answered the question you posted initially, could you please mark it as the “solution”?
This helps others quickly check, which topics still need help and people with similar issues can figure out the solution quicker.

Thank you very much and have a nice weekend!

1 Like

thank you, most of the server is set up again and i know what to do now.

have a nice weekend too :slight_smile:

1 Like