IcingawebDB does not write data to its configured MySQL database

Hello folks,

I recently stumbled across IcingaDB-Web and am currently trying to set it up on my test system, yet I seem to be failing :smiley:

Apparently, I went through the setup process all fine, both the icingadb-service as well as the icinga-redis service are running and show no errors in their logs, but there is no data being written to the MySQL-database.

I created the MySQL-resource in Icingaweb2 and referred to it within icingadb-web’s configuration and enabled the icingadb feature for icinga2 as well as the icingadb-web module for icingaweb2.

Is there anything I am blatantly missing? Do I need to tell Icinga2 to write data exclusively to the new redis database instead of the ido-pgsql one I had configured as backend before?

I’d be thankful for any hints,

Hello @dbodky!

Please share the output of icinga2 feature list on all (if >1) masters.


Hey @Al2Klimov, thank you very much for trying to help. The output on my master node is:

Disabled features: command compatlog elasticsearch gelf graphite influxdb livestatus opentsdb perfdata statusdata syslog
Enabled features: api checker debuglog icingadb ido-pgsql mainlog notification


Are there any Icinga 2 log messages about Icinga DB?

There are messages indeed and I could have checked that before I posted, sorry:

“Cannot connect to Permission denied”

I did not tweak icinga-redis nor icingadb in any way, what am I supposed to change configuration-wise in order to resolve this issue? I have not worked with redis before so I could use some guidance.

@dgoetz That’s SELinux, right?

Maybe, but instead of guessing because I do not even know which operating system is used it would say I need the operating system, selinux mode, module loaded, audit2allow output, …

If I should guess, set icinga2_can_connect_all to true.

Thank you very much, that did the trick. Sorry for not providing more information from the beginning, I never thought this was an issue connected to my OS. Anyways, for my system running Centos7, this was the solution: setsebool icinga2_can_connect_all 1