Icingaweb2 post-installation Zend Loader error

I almost certainly have a borked installation, having tried to install icinga2 and icingaweb2 from the repos on Ubuntu 18.04, which resulted in icinga 2.7 being installed. I then proceeded to do an upgrade following these steps but after seemingly all going well, I had no hosts showing up at all (not even localhost) in the dashboard.

Next, I did a do-release-upgrade since Ubuntu told me it was end of life, and after that, tried to uninstall and re-install from the disco repositories, still following the guide above, and after removing any databases in mysql created in the initial installation.

Then, just when everything seemed to have installed correctly, I got the following exception on the browser trying to access the setup wizard:

**Warning** : Uncaught ErrorException: require_once(Zend/Loader/Autoloader.php): failed to open stream: No such file or directory in /usr/share/php/Icinga/Application/ClassLoader.php:273 Stack trace: #0 /usr/share/php/Icinga/Application/ClassLoader.php(273): Icinga\Application\ApplicationBootstrap->Icinga\Application\{closure}(2, 'require_once(Ze...', '/usr/share/php/...', 273, Array) #1 /usr/share/php/Icinga/Application/ClassLoader.php(273): require_once() #2 /usr/share/php/Icinga/Application/ClassLoader.php(291): Icinga\Application\ClassLoader->requireZendAutoloader() #3 [internal function]: Icinga\Application\ClassLoader->loadClass('Zend_Controller...') #4 /usr/share/php/Icinga/Web/Request.php(14): spl_autoload_call('Zend_Controller...') #5 /usr/share/php/Icinga/Application/ClassLoader.php(303): require('/usr/share/php/...') #6 [internal function]: Icinga\Application\ClassLoader->loadClass('Icinga\\Web\\Requ...') #7 /usr/share/php/Icinga/Application/EmbeddedWeb.php(85): spl_autoload_call('Icinga\\Web\\Requ...') #8 /usr/ in  **/usr/share/php/Icinga/Application/ClassLoader.php**  on line  **273**

**Fatal error** : Icinga\Application\ClassLoader::requireZendAutoloader(): Failed opening required 'Zend/Loader/Autoloader.php' (include_path='/usr/share/icingaweb2/library/vendor:.:/opt/phpExcel/Classes:/usr/share/php') in  **/usr/share/php/Icinga/Application/ClassLoader.php**  on line  **273**

I realise that this is probably all my own doing, and providing the exact steps would be helpful but honestly the description above is about as good as I can do. Any suggestions on how I can troubleshoot this or at least wipe the install clean (without rebuilding the entire server) would be welcomed.

I uninstalled everything (icinga*), removed apt sources, ran an apt update, and then redid everything following this guide. Seems to have overcome the problem above.

1 Like