Icingaweb2 MYSQL_ATTR_INIT_COMMAND

Hi,

Icingaweb2 stopped working once i updated (apt update) my debian.

I’ve looked around the forums but couldn’t find any solution to this.

  • php7.4-mysql is installed
  • icinga configs are working
  • after i apt update, it’s showing me there is still 12 packages to update, they don’t update however with
    apt upgrade. one of the packages is php-common
  • everything was working fine before the apt update
  • i have a restore point on the VM, but i’m afraid it’s gonna happen again if i have to apt update, also the
    restore point is a bit old

Any help is appreciated.
Gabriel Laszlo

Bump.

Anyone have any Idea?

I updated the packages again in Debian, now I get

<?php /*! Icinga Web 2 | (c) 2014 Icinga Development Team | GPLv2+ */ require_once '/usr/share/php/Icinga/Application/webrouter.php';

when I open Icingaweb2.

Hello @bak0523!

Please share the apt logs from when it was working to now.

Best,
AK

Hi,

Thank you for your reply.

Here is the log from July 15 (it was working then):

Start-Date: 2020-07-15  15:57:00                                                                                                                                                                                                                                                   
Commandline: apt upgrade                                                                                                                                                                                                                                                          
Requested-By: icingaadmin (1000)                                                                                                                                                                                                                                                  
Upgrade: gcc-10-base:amd64 (10.1.0-5, 10.1.0-6), libicu67:amd64 (67.1-2, 67.1-3), libitm1:amd64 (10.1.0-5, 10.1.0-6), libquadmath0:amd64 (10.1.0-5, 10.1.0-6), libtsan0:amd64 (10.1.0-5, 10.1.0-6), libubsan1:amd64 (10.1.0-5, 10.1.0-6), liblsan0:amd64 (10.1.0-5, 10.1.0-6), libgomp1:amd64 (10.1.0-5, 10.1.0-6), libgcc-s1:amd64 (10.1.0-5, 10.1.0-6), libatomic1:amd64 (10.1.0-5, 10.1.0-6), libcc1-0:amd64 (10.1.0-5, 10.1.0-6), libstdc++6:amd64 (10.1.0-5, 10.1.0-6)                                                                                         
End-Date: 2020-07-15  15:57:04 
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                 
Start-Date: 2020-07-31  08:38:05                                                                                                                                                                                                                                                  
Commandline: apt upgrade                                                                                                                                                                                                                                                          
Requested-By: icingaadmin (1000)                                                                                                                                                                                                                                                  
Install: libstdc++-10-dev:amd64 (10.2.0-3, automatic), g++-10:amd64 (10.2.0-3, automatic), libasan6:amd64 (10.2.0-3, automatic), libwebpdemux2:amd64 (0.6.1-2+b1, automatic), libgcc-10-dev:amd64 (10.2.0-3, automatic), libhogweed6:amd64 (3.6-2, automatic), linux-image-5.7.0-2-amd64:amd64 (5.7.10-1, automatic), libnettle8:amd64 (3.6-2, automatic), cpp-10:amd64 (10.2.0-3, automatic), gcc-10:amd64 (10.2.0-3, automatic)                                                                                                                                   Upgrade: libmpc3:amd64 (1.1.0-1, 1.2.0~rc1-1), fdisk:amd64 (2.35.2-7, 2.36-1), libdevmapper1.02.1:amd64 (2:1.02.167-1+b1, 2:1.02.171-1), dmsetup:amd64 (2:1.02.167-1+b1, 2:1.02.171-1), bsdextrautils:amd64 (2.35.2-7, 2.36-1), libcups2:amd64 (2.3.3-1, 2.3.3-2), libsemanage1:amd64 (3.0-1+b3, 3.1-1), libfdisk1:amd64 (2.35.2-7, 2.36-1), python3-distutils:amd64 (3.8.3-2, 3.8.5-1), linux-libc-dev:amd64 (5.7.6-1, 5.7.10-1), libcurl4:amd64 (7.68.0-1, 7.68.0-1+b1), libpython3.8-dev:amd64 (3.8.4-1, 3.8.5-1), libldap-2.4-2:amd64 (2.4.50+dfsg-1, 2.4.50+dfsg-1+b1), gcc-9-base:amd64 (9.3.0-15, 9.3.0-16), snmp:amd64 (5.8+dfsg-3, 5.8+dfsg-4), libdw1:amd64 (0.176-1.1, 0.180-1), libc6-dev:amd64 (2.31-1, 2.31-2), libpython3.8-minimal:amd64 (3.8.4-1, 3.8.5-1), ingerman:amd64 (20161207-7, 20161207-8), libctf-nobfd0:amd64 (2.34.90.20200706-1, 2.35-1), git-man:amd64 (1:2.28.0~rc0-1, 1:2.28.0-1), libbrotli1:amd64 (1.0.7-6.1, 1.0.7-7), libsystemd0:amd64 (245.6-2, 245.7-1), gcc-10-base:amd64 (10.1.0-6, 10.2.0-3), grub-common:amd64 (2.04-8, 2.04-9), cpp-9:amd64 (9.3.0-15, 9.3.0-16), libmount1:amd64 (2.35.2-7, 2.36-1), libbz2-1.0:amd64 (1.0.8-3, 1.0.8-4), libelf1:amd64 (0.176-1.1, 0.180-1), binutils:amd64 (2.34.90.20200706-1, 2.35-1), cpp:amd64 (4:9.2.1-3.1, 4:10.1.0-1), libmagickwand-6.q16-6:amd64 (8:6.9.10.23+dfsg-2.1+deb10u1, 8:6.9.11.24+dfsg-1), bsdmainutils:amd64 (12.1.5, 12.1.6), libsnmp-base:amd64 (5.8+dfsg-3, 5.8+dfsg-4), libarchive13:amd64 (3.4.3-1, 3.4.3-1+b1), libitm1:amd64 (10.1.0-6, 10.2.0-3), g++:amd64 (4:9.2.1-3.1, 4:10.1.0-1), iswiss:amd64 (20161207-7, 20161207-8), wngerman:amd64 (20161207-7, 20161207-8), libc6:amd64 (2.31-1, 2.31-2), util-linux:amd64 (2.35.2-7, 2.36-1), libpython3.8:amd64 (3.8.4-1, 3.8.5-1), python3.8:amd64 (3.8.4-1, 3.8.5-1), runit-helper:amd64 (2.8.15, 2.9.0), gcc:amd64 (4:9.2.1-3.1, 4:10.1.0-1), coreutils:amd64 (8.32-2, 8.32-3), git:amd64 (1:2.28.0~rc0-1, 1:2.28.0-1), grub2-common:amd64 (2.04-8, 2.04-9), ncal:amd64 (12.1.5, 12.1.6), gnutls-bin:amd64 (3.6.14-2, 3.6.14-2+b1), udev:amd64 (245.6-2, 245.7-1), locales:amd64 (2.31-1, 2.31-2), libasan5:amd64 (9.3.0-15, 9.3.0-16), libquadmath0:amd64 (10.1.0-6, 10.2.0-3), grub-pc:amd64 (2.04-8, 2.04-9), libudev1:amd64 (245.6-2, 245.7-1), libstdc++-9-dev:amd64 (9.3.0-15, 9.3.0-16), systemd-timesyncd:amd64 (245.6-2, 245.7-1), calendar:amd64 (12.1.5, 12.1.6), mount:amd64 (2.35.2-7, 2.36-1), libsemanage-common:amd64 (3.0-1, 3.1-1), snmpd:amd64 (5.8+dfsg-3, 5.8+dfsg-4), binutils-x86-64-linux-gnu:amd64 (2.34.90.20200706-1, 2.35-1), grub-pc-bin:amd64 (2.04-8, 2.04-9), libblkid1:amd64 (2.35.2-7, 2.36-1), libunbound8:amd64 (1.10.1-1, 1.10.1-1+b1), libc-l10n:amd64 (2.31-1, 2.31-2), libsnmp35:amd64 (5.8+dfsg-3, 5.8+dfsg-4), libtsan0:amd64 (10.1.0-6, 10.2.0-3), librtmp1:amd64 (2.4+20151223.gitfa8646d.1-2+b1, 2.4+20151223.gitfa8646d.1-2+b2), libc-bin:amd64 (2.31-1, 2.31-2), libubsan1:amd64 (10.1.0-6, 10.2.0-3), g++-9:amd64 (9.3.0-15, 9.3.0-16), python3.8-minimal:amd64 (3.8.4-1, 3.8.5-1), linux-image-amd64:amd64 (5.7.6-1, 5.7.10-1), systemd-sysv:amd64 (245.6-2, 245.7-1), libuuid1:amd64 (2.35.2-7, 2.36-1), gcc-9:amd64 (9.3.0-15, 9.3.0-16), libgcrypt20:amd64 (1.8.5-5, 1.8.6-2), libselinux1:amd64 (3.1-1, 3.1-2), libpam-systemd:amd64 (245.6-2, 245.7-1), python3-lib2to3:amd64 (3.8.3-2, 3.8.5-1), liblsan0:amd64 (10.1.0-6, 10.2.0-3), systemd:amd64 (245.6-2, 245.7-1), libgomp1:amd64 (10.1.0-6, 10.2.0-3), libsmartcols1:amd64 (2.35.2-7, 2.36-1), eject:amd64 (2.35.2-7, 2.36-1), libmagickcore-6.q16-6:amd64 (8:6.9.10.23+dfsg-2.1+deb10u1, 8:6.9.11.24+dfsg-1), bzip2:amd64 (1.0.8-3, 1.0.8-4), bsdutils:amd64 (1:2.35.2-7, 1:2.36-1), binutils-common:amd64 (2.34.90.20200706-1, 2.35-1), libgcc-s1:amd64 (10.1.0-6, 10.2.0-3), nodejs-doc:amd64 (12.18.1~dfsg-1, 12.18.2~dfsg-1), dictionaries-common:amd64 (1.28.1, 1.28.2), libc-dev-bin:amd64 (2.31-1, 2.31-2), libbinutils:amd64 (2.34.90.20200706-1, 2.35-1), libpython3.8-stdlib:amd64 (3.8.4-1, 3.8.5-1), libgnutls30:amd64 (3.6.14-2, 3.6.14-2+b1), libnss3:amd64 (2:3.53.1-1, 2:3.55-1), libfreetype6:amd64 (2.10.2+dfsg-2, 2.10.2+dfsg-3), wget:amd64 (1.20.3-1+b2, 1.20.3-1+b3), python3.8-dev:amd64 (3.8.4-1, 3.8.5-1), libatomic1:amd64 (10.1.0-6, 10.2.0-3), libcc1-0:amd64 (10.1.0-6, 10.2.0-3), libcupsimage2:amd64 (2.3.3-1, 2.3.3-2), libgnutls-dane0:amd64 (3.6.14-2, 3.6.14-2+b1), libstdc++6:amd64 (10.1.0-6, 10.2.0-3), libradcli4:amd64 (1.2.11-1+b1, 1.2.11-1+b2), libnspr4:amd64 (2:4.25-1, 2:4.27-1), libcurl3-gnutls:amd64 (7.68.0-1, 7.68.0-1+b1), libctf0:amd64 (2.34.90.20200706-1, 2.35-1), libgcc-9-dev:amd64 (9.3.0-15, 9.3.0-16), aspell-de:amd64 (20161207-7, 20161207-8), imagemagick-6-common:amd64 (8:6.9.10.23+dfsg-2.1+deb10u1, 8:6.9.11.24+dfsg-1), python3-pyasn1:amd64 (0.4.2-4, 0.4.8-1)                                                                                                                                                                                                                      
End-Date: 2020-07-31  08:40:19   
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                               
Start-Date: 2020-07-31  11:25:11                                                                                                                                                                                                                                                   
Commandline: apt upgrade                                                                                                                                                                                                                                                          
Requested-By: icingaadmin (1000)                                                                                                                                                                                                                                                  
Install: libjson-c5:amd64 (0.15-1, automatic)                                                                                                                                                                                                                                     
Upgrade: bind9-dnsutils:amd64 (1:9.16.4-1, 1:9.16.4-1+b1), bind9-host:amd64 (1:9.16.4-1, 1:9.16.4- 1+b1), libcryptsetup12:amd64 (2:2.3.3-1, 2:2.3.3-1+b1), bind9-libs:amd64 (1:9.16.4-1, 1:9.16.4-1+b1)                                                                            
End-Date: 2020-07-31  11:25:13
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                      
Start-Date: 2020-07-31  11:25:57                                                                                                                                                                                                                                                  
Commandline: apt autoremove                                                                                                                                                                                                                                                       
Remove: libpython3.7-minimal:amd64 (3.7.3-2+deb10u1), libx265-165:amd64 (2.9-4), linux-image-4.19.0-9-amd64:amd64 (4.19.118-2+deb10u1), libisccfg163:amd64 (1:9.11.19+dfsg-1), ruby2.5:amd64 (2.5.5-3+deb10u1), libirs161:amd64 (1:9.11.19+dfsg-1), geoip-database:amd64 (20191224-2), perl-modules-5.28:amd64 (5.28.1-6), php7.3-mysql:amd64 (7.3.19-1~deb10u1), php7.3-curl:amd64 (7.3.19-1~deb10u1), ruby2.5-dev:amd64 (2.5.5-3+deb10u2), ruby2.5-doc:amd64 (2.5.5-3+deb10u2), libpython3.7-stdlib:amd64 (3.7.3-2+deb10u1), libisl19:amd64 (0.20-2), python3.7-minimal:amd64 (3.7.3-2+deb10u1), libisc1100:amd64 (1:9.11.5.P4+dfsg-5.1+deb10u1), libisc1105:amd64 (1:9.11.19+dfsg-1), libstdc++-9-dev:amd64 (9.3.0-16), libperl5.28:amd64 (5.28.1-6), libsnmp30:amd64 (5.7.3+dfsg-5+b2), libgeoip1:amd64 (1.6.12-6), g++-8:amd64 (8.4.0-4), g++-9:amd64 (9.3.0-16), libruby2.5:amd64 (2.5.5-3+deb10u2), libcupsfilters1:amd64 (1.27.5-2), liblwres161:amd64 (1:9.11.19+dfsg-1), libhogweed5:amd64 (3.5.1+really3.5.1-2), libnettle7:amd64 (3.5.1+really3.5.1-2), libnode64:amd64 (10.21.0~dfsg-1), libisccc161:amd64 (1:9.11.19+dfsg-1), libbind9-161:amd64 (1:9.11.19+dfsg-1), libjson-c4:amd64 (0.13.1+dfsg-9), libdns1104:amd64 (1:9.11.5.P4+dfsg-5.1+deb10u1), libdns1110:amd64 (1:9.11.19+dfsg-1), libcupsimage2:amd64 (2.3.3-2), libstdc++-8-dev:amd64 (8.4.0-4), ruby-did-you-mean:amd64 (1.2.1-1)              
End-Date: 2020-07-31  11:26:07
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  Start-Date: 2020-07-31  11:26:30                                                                                                                                                                                                                                                  Commandline: apt upgrade                                                                                                                                                                                                                                                          Requested-By: icingaadmin (1000)                                                                                                                                                                                                                                                  Upgrade: nodejs:amd64 (12.18.1~dfsg-1, 12.18.2~dfsg-1), rubygems-integration:amd64 
(1.11+deb10u1, 1.17.2), libnode72:amd64 (12.18.1~dfsg-1, 12.18.2~dfsg-1)                                                                                                                       
End-Date: 2020-07-31  11:26:33

Here is the log from August:

Start-Date: 2020-08-06  16:00:27
Commandline: apt upgrade
Requested-By: icingaadmin (1000)
Install: libjs-highlight.js:amd64 (9.12.0+dfsg1-5, automatic)
Upgrade: fdisk:amd64 (2.36-1, 2.36-2), libdevmapper1.02.1:amd64 (2:1.02.171-1, 2:1.02.171-2), dmsetup:amd64 (2:1.02.171-1, 2:1.02.171-2), bsdextrautils:amd64 (2.36-1, 2.36-2), libfdisk1:amd64 (2.36-1, 2.36-2), publicsuffix:amd64 (20200627.1701-1, 20200729.1725-1), libpython3.8-dev:amd64 (3.8.5-1, 3.8.5-2), snmp:amd64 (5.8+dfsg-4, 5.8+dfsg-5), libdw1:amd64 (0.180-1, 0.180-1+b1), libc6-dev:amd64 (2.31-2, 2.31-3), libpython3.8-minimal:amd64 (3.8.5-1, 3.8.5-2), libsystemd0:amd64 (245.7-1, 246-2), apt:amd64 (2.1.7, 2.1.8), libmount1:amd64 (2.36-1, 2.36-2), icinga2-bin:amd64 (2.11.4-1.buster, 2.12.0-1.buster), libelf1:amd64 (0.180-1, 0.180-1+b1), bsdmainutils:amd64 (12.1.6, 12.1.7), libsnmp-base:amd64 (5.8+dfsg-4, 5.8+dfsg-5), libarchive13:amd64 (3.4.3-1+b1, 3.4.3-2), icinga2-doc:amd64 (2.11.4-1.buster, 2.12.0-1.buster), python3-ply:amd64 (3.11-3, 3.11-4), nodejs:amd64 (12.18.2~dfsg-1, 12.18.3~dfsg-2), libc6:amd64 (2.31-2, 2.31-3), util-linux:amd64 (2.36-1, 2.36-2), libpython3.8:amd64 (3.8.5-1, 3.8.5-2), python3.8:amd64 (3.8.5-1, 3.8.5-2), ncal:amd64 (12.1.6, 12.1.7), udev:amd64 (245.7-1, 246-2), locales:amd64 (2.31-2, 2.31-3), libmpdec2:amd64 (2.4.2-3, 2.5.0-2), libx11-6:amd64 (2:1.6.9-2+b1, 2:1.6.10-3), libapt-pkg6.0:amd64 (2.1.7, 2.1.8), libudev1:amd64 (245.7-1, 246-2), systemd-timesyncd:amd64 (245.7-1, 246-2), calendar:amd64 (12.1.6, 12.1.7), mount:amd64 (2.36-1, 2.36-2), snmpd:amd64 (5.8+dfsg-4, 5.8+dfsg-5), libblkid1:amd64 (2.36-1, 2.36-2), libc-l10n:amd64 (2.31-2, 2.31-3), libsnmp35:amd64 (5.8+dfsg-4, 5.8+dfsg-5), libc-bin:amd64 (2.31-2, 2.31-3), python3.8-minimal:amd64 (3.8.5-1, 3.8.5-2), systemd-sysv:amd64 (245.7-1, 246-2), libuuid1:amd64 (2.36-1, 2.36-2), python-pkg-resources:amd64 (44.0.0-3, 44.1.1-1), libpam-systemd:amd64 (245.7-1, 246-2), icinga2-ido-mysql:amd64 (2.11.4-1.buster, 2.12.0-1.buster), systemd:amd64 (245.7-1, 246-2), libsmartcols1:amd64 (2.36-1, 2.36-2), eject:amd64 (2.36-1, 2.36-2), apt-utils:amd64 (2.1.7, 2.1.8), libx11-data:amd64 (2:1.6.9-2, 2:1.6.10-3), icinga2-common:amd64 (2.11.4-1.buster, 2.12.0-1.buster), bsdutils:amd64 (1:2.36-1, 1:2.36-2), nodejs-doc:amd64 (12.18.2~dfsg-1, 12.18.3~dfsg-2), bash:amd64 (5.0-6, 5.0-7), libc-dev-bin:amd64 (2.31-2, 2.31-3), libpython3.8-stdlib:amd64 (3.8.5-1, 3.8.5-2), libnode72:amd64 (12.18.2~dfsg-1, 12.18.3~dfsg-2), python3.8-dev:amd64 (3.8.5-1, 3.8.5-2), apt-transport-https:amd64 (2.1.7, 2.1.8), libjson-c3:amd64 (0.12.1+ds-2, 0.12.1+ds-2+deb10u1), icinga2:amd64 (2.11.4-1.buster, 2.12.0-1.buster), libjpeg62-turbo:amd64 (1:2.0.5-1, 1:2.0.5-1.1), python-ply:amd64 (3.11-3, 3.11-4)
End-Date: 2020-08-06  16:01:31

Start-Date: 2020-08-07  09:02:08
Commandline: apt autoremove
Requested-By: icingaadmin (1000)
Remove: libmpdec2:amd64 (2.5.0-2)
End-Date: 2020-08-07  09:02:09

Start-Date: 2020-08-07  09:02:32
Commandline: apt upgrade
Requested-By: icingaadmin (1000)
Upgrade: libcap2:amd64 (1:2.36-1, 1:2.42-2), libcap2-bin:amd64 (1:2.36-1, 1:2.42-2)
End-Date: 2020-08-07  09:02:33

Start-Date: 2020-08-12  16:14:11
Commandline: apt upgrade
Requested-By: icingaadmin (1000)
Upgrade: libstdc++-10-dev:amd64 (10.2.0-3, 10.2.0-5), g++-10:amd64 (10.2.0-3, 10.2.0-5), gcc-9-base:amd64 (9.3.0-16, 9.3.0-17), gcc-10-base:amd64 (10.2.0-3, 10.2.0-5), apt:amd64 (2.1.8, 2.1.10), cpp-9:amd64 (9.3.0-16, 9.3.0-17), libgpgme11:amd64 (1.13.1-9, 1.14.0-1), libitm1:amd64 (10.2.0-3, 10.2.0-5), nodejs:amd64 (12.18.3~dfsg-2, 12.18.3~dfsg-4), libasan5:amd64 (9.3.0-16, 9.3.0-17), libasan6:amd64 (10.2.0-3, 10.2.0-5), libquadmath0:amd64 (10.2.0-3, 10.2.0-5), apache2-data:amd64 (2.4.43-1, 2.4.46-1), libapt-pkg6.0:amd64 (2.1.8, 2.1.10), libgcc-10-dev:amd64 (10.2.0-3, 10.2.0-5), libunbound8:amd64 (1.10.1-1+b1, 1.11.0-1), libtsan0:amd64 (10.2.0-3, 10.2.0-5), libubsan1:amd64 (10.2.0-3, 10.2.0-5), pci.ids:amd64 (0.0~2020.05.29-1, 0.0~2020.07.21-1), libxxhash0:amd64 (0.7.4-1, 0.8.0-1), gcc-9:amd64 (9.3.0-16, 9.3.0-17), liblsan0:amd64 (10.2.0-3, 10.2.0-5), libgomp1:amd64 (10.2.0-3, 10.2.0-5), apt-utils:amd64 (2.1.8, 2.1.10), libgcc-s1:amd64 (10.2.0-3, 10.2.0-5), nodejs-doc:amd64 (12.18.3~dfsg-2, 12.18.3~dfsg-4), libnode72:amd64 (12.18.3~dfsg-2, 12.18.3~dfsg-4), apache2-bin:amd64 (2.4.43-1, 2.4.46-1), rsync:amd64 (3.2.2-2, 3.2.3-1), libzstd1:amd64 (1.4.5+dfsg-3, 1.4.5+dfsg-4), libcryptsetup12:amd64 (2:2.3.3-1+b1, 2:2.3.3-2), apt-transport-https:amd64 (2.1.8, 2.1.10), cpp-10:amd64 (10.2.0-3, 10.2.0-5), libatomic1:amd64 (10.2.0-3, 10.2.0-5), libcc1-0:amd64 (10.2.0-3, 10.2.0-5), apache2:amd64 (2.4.43-1, 2.4.46-1), libstdc++6:amd64 (10.2.0-3, 10.2.0-5), apache2-utils:amd64 (2.4.43-1, 2.4.46-1), libheif1:amd64 (1.6.1-1+b1, 1.6.1-1+b2), gcc-10:amd64 (10.2.0-3, 10.2.0-5), libgcc-9-dev:amd64 (9.3.0-16, 9.3.0-17)
End-Date: 2020-08-12  16:14:42

Start-Date: 2020-08-12  16:16:06
Commandline: apt full-upgrade
Requested-By: icingaadmin (1000)
Install: libldb2:amd64 (2:2.1.4-2, automatic), python3-gpg:amd64 (1.14.0-1, automatic), python3-ldb:amd64 (2:2.1.4-2, automatic), python3-tdb:amd64 (1.4.3-1, automatic), python3-samba:amd64 (2:4.12.5+dfsg-3, automatic), python3-talloc:amd64 (2.3.1-1, automatic), python3-crypto:amd64 (2.6.1-13.1+b1, automatic)
Upgrade: php-common:amd64 (2:69, 2:76), libwbclient0:amd64 (2:4.9.5+dfsg-5+deb10u1, 2:4.12.5+dfsg-3), samba-dsdb-modules:amd64 (2:4.9.5+dfsg-5+deb10u1, 2:4.12.5+dfsg-3), samba-libs:amd64 (2:4.9.5+dfsg-5+deb10u1, 2:4.12.5+dfsg-3), samba-common:amd64 (2:4.9.5+dfsg-5+deb10u1, 2:4.12.5+dfsg-3), libsmbclient:amd64 (2:4.9.5+dfsg-5+deb10u1, 2:4.12.5+dfsg-3), smbclient:amd64 (2:4.9.5+dfsg-5+deb10u1, 2:4.12.5+dfsg-3), samba-common-bin:amd64 (2:4.9.5+dfsg-5+deb10u1, 2:4.12.5+dfsg-3), libtdb1:amd64 (1.3.16-2+b1, 1.4.3-1)
Remove: php7.3-xml:amd64 (7.3.19-1~deb10u1), libldb1:amd64 (2:1.5.1+really1.4.6-3), python-tdb:amd64 (1.3.16-2+b1), python-samba:amd64 (2:4.9.5+dfsg-5+deb10u1), php7.3-readline:amd64 (7.3.19-1~deb10u1), php7.3:amd64 (7.3.19-1~deb10u1), php7.3-json:amd64 (7.3.19-1~deb10u1), php7.3-ldap:amd64 (7.3.19-1~deb10u1), php7.3-common:amd64 (7.3.19-1~deb10u1), php7.3-intl:amd64 (7.3.19-1~deb10u1), php7.3-opcache:amd64 (7.3.19-1~deb10u1), php7.3-cli:amd64 (7.3.19-1~deb10u1), python-ldb:amd64 (2:1.5.1+really1.4.6-3), libapache2-mod-php7.3:amd64 (7.3.19-1~deb10u1)
End-Date: 2020-08-12  16:16:19

Start-Date: 2020-08-12  16:21:59
Commandline: apt autoremove
Requested-By: icingaadmin (1000)
Remove: libpython2.7:amd64 (2.7.18-1), python-talloc:amd64 (2.1.14-2), python-crypto:amd64 (2.6.1-9+b1), python-gpg:amd64 (1.12.0-6)
End-Date: 2020-08-12  16:21:59

Start-Date: 2020-08-12  16:24:28
Commandline: apt install libapache2-mod-php
Requested-By: icingaadmin (1000)
Install: libapache2-mod-php:amd64 (2:7.4+76)
End-Date: 2020-08-12  16:24:28

Everything worked before 31.07.

Kind regards,
Gabriel

I see a removal of PHP <-> MySQL:

But no installation of an equivalent.

I guess that’s your problem.

Hi,

I’ve tried sudo apt install php7.3-mysql:amd64
It says i need php7.3-common (= 7.3.19-1~deb10u1)

Then with sudo apt install php7.3-common
It says that i need php-common (>= 1:35)

I’ve tried sudo apt install php-common
Then it says php-common is already the newest verison (2:76)

Kind of a dead end…

But like I already said, php7.4-mysql is already installed, shouldn’t that be the equivalent?

Are you sure about this?

sudo apt install php7.4-mysql
Paketlisten werden gelesen… Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen… Fertig
php7.4-mysql ist schon die neueste Version (7.4.5-1+b1).
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 3 nicht aktualisiert.

ENG:

sudo apt install php7.4-mysql
Packet lists are read… Done
Dependency tree is built.
Status information is read in… Ready
php7.4-mysql is already the latest version (7.4.5-1+b1).
0 updated, 0 newly installed, 0 to be removed and 3 not updated

Please put the PHP file from the first example in your WWW root, open it in the web browser and share a screenshot.

Anmerkung 2020-08-13 125927

Doesn’t seem to work.
I can copy php -i from the terminal if it helps.

It gives a blank page on any other browser.

What packages like *apache-mod-php* are installed?

What do you mean by that?

I mean which packages of the installed ones contain “apache-mod-php”?

root@VM-140:/var/www# apt list --installed | grep apache2

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

apache2-bin/unstable,now 2.4.46-1 amd64 [Installiert,automatisch]
apache2-data/unstable,now 2.4.46-1 all [Installiert,automatisch]
apache2-utils/unstable,now 2.4.46-1 amd64 [Installiert,automatisch]
apache2/unstable,now 2.4.46-1 amd64 [Installiert,automatisch]
libapache2-mod-php7.4/unstable,now 7.4.5-1+b1 amd64 [installiert]
libapache2-mod-php/unstable,now 2:7.4+76 all [installiert]

root@VM-140:/var/www# apt list --installed | grep php

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

libapache2-mod-php7.4/unstable,now 7.4.5-1+b1 amd64 [installiert]
libapache2-mod-php/unstable,now 2:7.4+76 all [installiert]
php-common/unstable,now 2:76 all [installiert]
php-curl/unstable,now 2:7.4+76 all [installiert]
php-gmp/unstable,now 2:7.4+76 all [installiert]
php-icinga/icinga-buster,now 2.8.1-1.buster all [Installiert,automatisch]
php-imagick/unstable,now 3.4.4-4.1 amd64 [Installiert,automatisch]
php-intl/unstable,now 2:7.4+76 all [Installiert,automatisch]
php-ldap/unstable,now 2:7.4+76 all [Installiert,automatisch]
php-mysql/unstable,now 2:7.4+76 all [Installiert,automatisch]
php-xml/unstable,now 2:7.4+76 all [Installiert,automatisch]
php7.4-cli/unstable,now 7.4.5-1+b1 amd64 [Installiert,automatisch]
php7.4-common/unstable,now 7.4.5-1+b1 amd64 [Installiert,automatisch]
php7.4-curl/unstable,now 7.4.5-1+b1 amd64 [Installiert,automatisch]
php7.4-gmp/unstable,now 7.4.5-1+b1 amd64 [Installiert,automatisch]
php7.4-intl/unstable,now 7.4.5-1+b1 amd64 [Installiert,automatisch]
php7.4-json/unstable,now 7.4.5-1+b1 amd64 [Installiert,automatisch]
php7.4-ldap/unstable,now 7.4.5-1+b1 amd64 [Installiert,automatisch]
php7.4-mysql/unstable,now 7.4.5-1+b1 amd64 [installiert]
php7.4-opcache/unstable,now 7.4.5-1+b1 amd64 [Installiert,automatisch]
php7.4-readline/unstable,now 7.4.5-1+b1 amd64 [Installiert,automatisch]
php7.4-xml/unstable,now 7.4.5-1+b1 amd64 [Installiert,automatisch]
php7.4/unstable,now 7.4.5-1 all [installiert]
php/unstable,now 2:7.4+76 all [installiert]
rh-php73-php-gmp/now 7.3.7-3 amd64 [Installiert,lokal]

Does this help?

Only ones with “apache-mod-php” are:

libapache2-mod-php7.4/unstable,now 7.4.5-1+b1 amd64 [installiert]
libapache2-mod-php/unstable,now 2:7.4+76 all [installiert]

Please share the output of apache2ctl -M

root@VM-140:/var/www# apache2ctl -M
Loaded Modules:
core_module (static)
so_module (static)
watchdog_module (static)
http_module (static)
log_config_module (static)
logio_module (static)
version_module (static)
unixd_module (static)
access_compat_module (shared)
alias_module (shared)
auth_basic_module (shared)
authn_core_module (shared)
authn_file_module (shared)
authz_core_module (shared)
authz_host_module (shared)
authz_user_module (shared)
autoindex_module (shared)
deflate_module (shared)
dir_module (shared)
env_module (shared)
filter_module (shared)
mime_module (shared)
mpm_prefork_module (shared)
negotiation_module (shared)
reqtimeout_module (shared)
rewrite_module (shared)
setenvif_module (shared)
status_module (shared)
root@VM-140:/var/www#

mod_php is disabled – that’s the root cause of this one:

ERROR: Module mod_php does not exist!

Where can I get it from?

I don’t really know why is disabled…
I dind’t do anything apart from updating the pacakges.

Which version/codename?