[icingaweb2-module-x509]: Does not update the servers certs on the dashboard

We are in process of updating the ssl cert across for all our servers and we use icinga 2 to display certificate status. Currently icinga dashboard does not show the updated certs on the servers being monitoring despite of the fact that openssl gives the updated certificate for those instances. We have this module: https://github.com/Icinga/icingaweb2-module-x509 installed for cert monitoring by Icinga and on the dashboard I see these errors:

#0 /usr/share/icingaweb2/modules/x509/application/controllers/JobController.php(55): Icinga\Web\Controller\ActionController->assertPermission(String)
#1 /usr/share/icinga-php/vendor/vendor/shardj/zf1-future/library/Zend/Controller/Action.php(516): Icinga\Module\X509\Controllers\JobController->indexAction()
#2 /usr/share/php/Icinga/Web/Controller/Dispatcher.php(76): Zend_Controller_Action->dispatch(String)
#3 /usr/share/icinga-php/vendor/vendor/shardj/zf1-future/library/Zend/Controller/Front.php(954): Icinga\Web\Controller\Dispatcher->dispatch(Object(Icinga\Web\Request), Object(Icinga\Web\Response))
#4 /usr/share/php/Icinga/Application/Web.php(294): Zend_Controller_Front->dispatch(Object(Icinga\Web\Request), Object(Icinga\Web\Response))
#5 /usr/share/php/Icinga/Application/webrouter.php(105): Icinga\Application\Web->dispatch()
#6 /usr/share/icingaweb2/public/index.php(4): require_once(String)
#7 {main}.

I have done basically debugging like following but it has not helped resolve the issue:

  • Icinga restart
  • rescan and clean up of certs
  • restart of mysql db
  • restart of php-fpm module

Can someone please help?

Kinjal Brahmbhatt

your user doesn’t have the permission to access the config, sadly for the current version you need the permission:


to list jobs


also you tried to access
and not

x509/usage shows you the certificates scanned by x509

if you certificate still doesn’t show up after successful scan, it might me a firewall / dns issue