Icingaweb2 dashboard not functional

The dashboard when I log into Icingaweb2 just stays at “Loading” under service problems and all the other fields.

I can see host information etc, if I go looking for it it’s only the dashboard that’s busted.

Maybe permissions? but where.

This was working a minute ago, maybe 10 minutes ago. I have no idea why it no longer works.

Service Problems


Recently Recovered Services


Host Problems


of note is that if I click on one of these links, it will work.

Any news on this one? Having the same issue.
When using the monitoring module instead it’s all working,
just with icingadb it’s loading…, loading…, loading…

I don’t think it’s a permission issue, since I am using the admin account to test.

Might or might not be related, but the icingadb module lists the monitoring module as a dependency.
Doesn’t that defeat its purpose? Shouldn’t it be either or?

If I find anything further I’ll post.

Cheers, Jan

If this only happens with Icinga DB Web while the monitoring module is disabled, it’s because the RC1 release doesn’t provide any dashboards. That your dashboard is not simply empty, might be because you’ve edited the monitoring module dashboards in the past and now they show up as custom dashboards.

This is only the case because some code assets are being used by Icinga DB Web, the IDO doesn’t need to be configured for this. It also won’t be a dependency anymore with the first stable release.

1 Like

Thanks for clearing this up!

Interestingly enough, though, the configured links in the dashboard point to “icingadb” and not to “monitoring”. This changes if the monitoring module is enabled. So I misfigured this as a hint that sth. else was wrong.

Will later versions of Icinga DB web provide dashboards?
So I guess in the meantime I just use the tactical overview of Icinga DB web.

The links point to Icinga DB Web? Are you running the RC1 at all or maybe a version of the master? Because of course will Icinga DB Web provide dashboards. It already does so, if the monitoring module is disabled, in the master.

I was pulling the latest docker image. You are right it is the master, version is:

So, this version should provide dashboards already? Then we’re back to square one :wink:

Thanks for your patience!

Yeah, well, the thing is, the master of Icinga DB Web is that nightly, that there’s no easy way to run it with all dependencies intact easily. Without going into too much detail, you’d have to make sure you’re running Icinga Web 2’s master, have the ipl module installed in a non-existent version and… I probably forgot something anyway.

So, take your pick:

  • Use the release candidate
  • Try updating all dependencies, what you’d have to figure out by yourself mostly
  • Wait for the stable release (no public date yet :confused: )

I’d recommend the release candidate, although already ancient at this time.

Thanks for the insite and advice! Very helpful.

I just tried my production Icinga instance and was quite puzzled why it showed the same error as the development instance … bottom line is very embarrasing: Firefox is/was the problem, which is probably my setup’s fault. All works like a charm in Chrome.

Sorry about the noise!

Only with Firefox you say? :thinking: Works for me, with version 85.0. Are you using an ESR version by chance? If so, it’s probably a bug in Firefox. Or something else specific to the ESR builds. By which I absolutely didn’t want to imply that ESR builds are particularly bugged… :sweat_smile:

It is an ESR version:
ii firefox-esr 68.12.0esr-1~deb10u1