Icingaweb nagvis integration authentication issue

Hi,
I’m currently following https://github.com/Icinga/icingaweb2-module-nagvis/blob/master/doc/02-Installation.md#icinga-web-2-configuration

But i run into an issue with the authentication. When i set the [cookie] path = / in the icingaweb2 configuration I am unable to login to icingaweb2. The login page just reappears. If i then change the config back by removing the cookie section. Everything seems to work for a while.

The nagvis integration works fine. But a few hours later i get not authenticated when trying to open a map in nagvis. (I suppose the session timed out or cookie expired).

At that point I can’t seem to get it back to working except when renabling the cookie section again do a login remove the cookie section again. And it works again for a while.

Anyone an idea on how to fix this?

Hi, please try the following settings in “/etc/icingaweb2/config.ini”:

[cookie]
path = "/"

Well that is exactly the problem i am facing.
When i set it i can’t login to icingaweb2. until i unset it again. (the login form just reappears)
Then it works till the cookie expires and then i get the not authenticated again.

Hello there :slight_smile:
I think Markus was referring to the quotes around the slash here?
Or does it not work either way?

Just checked with the quotes to be sure. But still facing the same issue.

Hi!

I just talked to Markus about it again, and we don’t exactly know what is causing your issue.
From what he said, he is working with an environment that used to have a similar issue this week and will look into it further. :slight_smile:

Hi,

can you please remove the NagVis cache and test again?

# find /usr/local/nagvis/var/ -type f -delete

Still having the same issue :frowning: