Icingaweb doesn't display correct output


I run a check in the masters for some licenses and it seems that icingaweb displays a previous output.
When I run the script manually in the masters I get different results from what is being displayed in IcingaWeb.

The logs don’t say anything useful or I am missing it.
Where should I start looking to solve this?


OS: Centos Stream 8
Icinga Web 2 version: 2.9.5
Icinga version: version: 2.13.2-1
Director version: 1.7.2


what is the output in both versions? Is there an error message? Maybe something with a hint of missing permissions?
How you try the check on the console? As sudo or as icinga-user? If you turned on SELinux, did you check the error messages there?

1 Like

Thanks for your quick reply and thanks for reminding me about SELinux :sweat_smile:
I had to change the context of the script, forgot to do it.

Again thank you!

1 Like

No problem, your welcome. I often wasted a lot of time because of that s**** already :sweat_smile:

1 Like