IcingaDB: unexpected database schema version: v3 (expected v4)


I´ve searched a little bit at the community and it seems that there were similar problems, but I couldn´t solve it by the advices given so far. I can´t start IcingaDB anymore at my ubuntu vm. Error:
unexpected database schema version: v3 (expected v4), please make sure you have applied all database migrations after upgrading Icinga DB

I´ve checked if there are open migration at icinga director and with

icingacli director migration pending --verbose

Also I tried:

 icinga-redis-cli flushall

But nothing helped so far: I haven´t found any upgrade schema at /usr/share/doc/icingadb/ or /usr/share/icingadb/schema/mysql/upgrades/ which could be related to the problem. The most recent upgrade version is 1.1.1.sql. Has anyone a hint, how I could solve / debug this further?

1 Like


As you said, there is a schema upgrade to 1.1.1.
Did you do this schema upgrade to version 1.1.1?


mysql -u root -p icingadb < /usr/share/icingadb/schema/mysql/upgrades/1.1.1.sql

This solved the problem for me.

Edit: Releasing Icinga DB 1.1.1


1 Like

Thanks, that did the trick. The version numbers at the log were misleading.