IcingaDB not running

Hi Community,

does someone have some advice for me?
Still getting the following message after walking through the install docs according to IcingaDB an IcingaDB-Web

#  /usr/sbin/icingadb --config /etc/icingadb/config.yml
2022-12-08T16:56:58.284+0100    INFO    icingadb        Starting Icinga DB
2022-12-08T16:56:58.284+0100    INFO    icingadb        Connecting to database at 'localhost:0'
2022-12-08T16:56:58.285+0100    INFO    icingadb        Connecting to Redis at 'localhost:6380'
2022-12-08T16:57:01.286+0100    INFO    icingadb        Waiting for Icinga 2 to write into Redis, please make sure you have started Icinga 2 and the Icinga DB feature is enabled

DB Connect seems to work the correct way, DB password length is 11 only alphanumeric in it
image

Redis setting in icingadb module gives me this message
image

Feature is enabled and set the DB pass in /etc/icingadb/config.yml

# icingacli module list | grep icingadb
icingadb       1.0.2     enabled   Icinga DB Web

Service icinga2, icingadb, icingadb-redis state running

  • Icinga DB Web version (System - About): 1.0.2
  • Icinga Web 2 version (System - About): 2.11.2
  • Web browser: Chrome latest
  • Icinga 2 version (icinga2 --version): version: r2.13.6-1
  • Icinga DB version (icingadb --version): Icinga DB version: v1.1.0
  • PHP version used (php --version): PHP 8.1.13
  • Server operating system and version: Debian GNU/Linux 11 (bullseye)

Hello @B3RN0UT!

This message…

… means not the Icinga Web module…

… but Icinga 2, see icinga2 feature list.

Best,
A/K

1 Like

Make sure that u entered here the correct details for your database-connection:

/etc/icingadb/config.yml

After that I prefer to do a restart of your icinga-system. :slight_smile:

1 Like

Thanks a lot that was my main mistake (as for everyone I guess :slight_smile: )
Bit confusing at this point that the module name and the feature name is similiar.

So

icinga2 feature enable icingadb

and

 systemctl restart icinga2

did the trick.

Thanks again

1 Like