Icinga2 with IcingaDB Daemon, Redis and Icinga Web 2 not working

Hi guys,
I have setup an new Icinga2 instance and followed the following articels

During the Installation I got no errors and the Icinga2 shopuld be working.
BUT no Server (only the localhost) was displayed on the Webpage.
Under “Configuration” → Modules → I saw that the Monitoring Modul was disabled.
I enabled the Monitoring Module but now I get the Error on the “Dashbord” No backend has been configured

How can I configure a Backend for the Monitoring Module, because the IDO is deprecated for the new Icinga Web 2, isn’t it?

I found nothing on the Internet to solve my strange Problem. WOuld be great if someone can give a me hint how to solve this strange Problem.


  • icinga-mon:~# icinga2 feature list
    Disabled features: command compatlog debuglog elasticsearch gelf graphite influxdb influxdb2 livestatus opentsdb perfdata statusdata syslog
    Enabled features: api checker icingadb mainlog notification

  • Web browser used (Apache/2.4.56 (Debian)

  • Icinga 2 version used (r2.13.7-1)

  • PHP version used (PHP 7.4.33)

  • Linux icinga-mon 5.10.0-22-cloud-amd64 #1 SMP Debian 5.10.178-3 (2023-04-22) x86_64 GNU/Linux (Azure VM)

The Monitoirng Module and IDO are the old way.
The Icingadb-web module, Redis and icingadb are the new way.
You can run both but for a new setup it makes IMHO more sense to only go the new way.

Why did you expect more then the localhost? Did you configure more with the Director module?

I have been done the “new way”! Does it mean I don’t need the monitoring Module?
If I disable the Monitor Module I can’t see any configured Server, only the localhost.
And I don’t use the Director module?

How many servers did you configure and how.
The “new way” doesn’t need the monitoring module.

Not using the Director is sad because it writes the config for you and it’s versioned.
It took some getting used to it but now I don’t want to go back to writhing everything by hand.

yes you are right. I disabled the Monitoring Module and is should be OK now.
FYI: The Icinga Master is a complete new one.
But now I have another problem,
When I add a debian11 Host (Bullseye) everything is fine, but when a add a Debian10 Host (Buster)
I got an error.
Did you know this Problem?

information/ApiListener: New client connection for identity ‘server’ from (certificate validation failed: code 18: self signed certificate)
warning/ApiListener: Timeout while processing incoming connection from xxxxx:39500

information/ApiListener: No data received on new API connection from xxxxx:39500. Ensure that the remote endpoints are properly configured in a cluster setup.

Maybe start a new thread if it isn’t resolved by just copying the Icinga master CA cert to the client.
Icinga has it’s own PKI and you need to copy the CA to the client and sign the client cert with the PKI on the master.

If you use the Director you get per host a nice generated script that does all this for you.

Yes ic will open a thread, because the copy of the CA cert don’t resolve my problem :frowning:

Thanks for you Support :+1: