Icinga2 upgrade failed


My Icinga distributed monitoring has 1 master, 2 satellites, and 6 agents. Each satellite connects to 3 agents.
The operation system of both satellites are the same: Ubuntu 18.04.5 LTS (codename: bionic).
I ran the following commands to upgrade icinga version in both satellites:
echo “deb http://packages.icinga.com/ubuntu icinga-bionic main” > /etc/apt/sources.list.d/icinga2.list
echo “deb-src http://packages.icinga.com/ubuntu icinga-bionic main” > /etc/apt/sources.list.d/icinga2.list
apt update
apt install icinga2 monitoring-plugins

I could upgrade satellite2 successfully but can not upgrade satellite1. satellite1always shows “icinga2 is already the newest version (2.8.1-0ubuntu2).” Could any one give me some help??? I don’t know why I can not upgrade satellite 1.

apt list check:
root@sattelite1:~# apt list | grep icinga2

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

icinga2/bionic,now 2.8.1-0ubuntu2 amd64 [installed]
icinga2-bin/bionic,now 2.8.1-0ubuntu2 amd64 [installed,automatic]
icinga2-classicui/bionic 2.8.1-0ubuntu2 all
icinga2-common/bionic,now 2.8.1-0ubuntu2 all [installed,automatic]
icinga2-dbg/bionic 2.8.1-0ubuntu2 amd64
icinga2-doc/bionic,now 2.8.1-0ubuntu2 all [installed,automatic]
icinga2-ido-mysql/bionic 2.8.1-0ubuntu2 amd64
icinga2-ido-pgsql/bionic 2.8.1-0ubuntu2 amd64
icinga2-studio/bionic 2.8.1-0ubuntu2 amd64
libicinga2/bionic,now 2.8.1-0ubuntu2 amd64 [installed,automatic]
libmonitoring-icinga2-client-rest-perl/bionic 2.0.0-1 all
vim-icinga2/bionic 2.8.1-0ubuntu2 all

root@sattelite2:~# apt list | grep icinga2

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

icinga2/icinga-bionic 2.12.0-1.bionic amd64 [upgradable from: 2.11.4-1.bionic]
icinga2-bin/icinga-bionic 2.12.0-1.bionic amd64 [upgradable from: 2.11.4-1.bionic]
icinga2-classicui/icinga-bionic 2.9.2-1.bionic all
icinga2-common/icinga-bionic 2.12.0-1.bionic all [upgradable from: 2.11.4-1.bionic]
icinga2-dbg/icinga-bionic 2.12.0-1.bionic amd64
icinga2-doc/icinga-bionic 2.12.0-1.bionic all [upgradable from: 2.11.4-1.bionic]
icinga2-ido-mysql/icinga-bionic 2.12.0-1.bionic amd64 [upgradable from: 2.11.4-1.bionic]
icinga2-ido-pgsql/icinga-bionic 2.12.0-1.bionic amd64
icinga2-studio/icinga-bionic 2.8.4-1.bionic amd64
libicinga2/icinga-bionic 2.9.2-1.bionic amd64
libmonitoring-icinga2-client-rest-perl/bionic 2.0.0-1 all
vim-icinga2/icinga-bionic 2.12.0-1.bionic all [upgradable from: 2.11.2-1.bionic]


please verify that the sources.list entry for the Icinga repository is there on statellite1. Also ensure that you ran apt update after making changes on the sources.list

Maybe the package is put on hold? You can show hold packages with apt-mark showhold.

Best regards

Thank you so much. yup. Problem solved.