Icinga2 on Scientific Linux?

Hi All,

Has anyone any experience with installing Icinga2 on Scientific Linux? I have an issue with installing Icingaweb2, especially with the rh-php package dependencies.

Any hint would be appreciated.

(Icinga2 2.13, Scientific Linux 7.9)


Have you tried to add the SCL repository? CentOS Mirror
It should work on an EL derivate.

Try installing these, rh-php73-php-mysqlnd, sclo-php73-php-pecl-imagick and rh-php73-php-fpm
from SCL and Epel repos. I installed the rest of php74 from remi.

Hi Mark,

I’ve already tried it, but I had cross dependency issues, see the my answer to Dirk above.

The big question is, should I still try with Sci.Linux or ask for a new RedHat VM machine?


It may be worth considering using a container (Docker, podman) for icingaweb2. Depending on your comfort level and other requirements it’s hard to say what the best path forward for you would be.

Hello Lee,

Thanks for the idea. Unfortunately I’m not familiar with container technologies and I don’t have any Docker environment. But, maybe it’s time to start to deal with it :slight_smile:


1 Like

Hmm, not sure. Here is how I started my install on CentOS 7.9. Scientific Linux is no longer being maintained, may want to try CentOS7. But then again CentOS(8) was dropped from RedHat, it is been changed to CentOS Stream. Anyway, that is another story. We are still scrambling trying to figure out what will be the next OS.

Disable selinux:
sestatus → disabled, rebooted

yum install https://packages.icinga.com/epel/icinga-rpm-release-7-latest.noarch.rpm -y

yum install icinga2 nagios-plugins-all mariadb-server mariadb icinga2-ido-mysql httpd icingaweb2 icingacli rh-php73-php-mysqlnd -y --nogpgcheck (for testing, will get key if poc is good)

yum install php74-php php74-php-cli php74-php-common php74-php-devel php74-php-gd php74-php-intl php74-php-json php74-php-ldap php74-php-mysqlnd php74-php-oci8 php74-php-pdo php74-php-pear php74-php-pecl-http php74-php-pecl-mysql php74-php-pecl-propro php74-php-pecl-raphf php74-php-sodium php74-php-xml php74-runtime -y --nogpgcheck

yum install sclo-php73-php-pecl-imagick rh-php73-php-fpm -y --nogpgcheck

Symlink to get config files in common areas:
ln -s /opt/remi/php74/root/usr/bin/php /usr/bin/php
ln -s /etc/opt/remi/php74/php.ini /etc/php.ini

Hope this helps.

1 Like

Hello Mark,

Thanks for the help!
Finally I solved it in a similar way.