Icinga2, influxdb and grafana


I’m running a docker setup with icinga2, icingaweb2 and icingadb. This is a fresh install since I need to move away from the (very) old installation.

Question: need to set up access to influxdb and graphing in Grafana because there is lots of historical data I don’t want to loose.
So, I understand that I can manually add the grafana module into the icinga2 container (works) and then activate the monitoring module (works).

What does not work is the ido-mysql part. I am asked to setup a backend, but it seems the ido-mysql stuff is not available anymore… Anybody can help me?

I think, with the release of IcingaDB (which obviously is favored now), the direct inclusion of the feature has been removed or better, the package containing the feature isn’t installed as a dependency anymore.
If you install icinga2-ido-mysql the feature will be there again.

But, ido-mysql isn’t needed for an installation with icingadb. Why do you want to activate/use it?

1 Like

@danielbierstedt you don’t need the monitoring module for the grafana module. This is actually a wrong dependency in the module, see: icingaweb - grafana, Dependencies Unmet dependencies found · Issue #294 · Mikesch-mp/icingaweb2-module-grafana · GitHub
The monitoring module is the frontend for the IDO backend, the icingadbweb module is the frontend for the IcingaDB backend. I just switched to IcingaDB this week and the grafana module is still working. However, the grafana module was enabled in my setup, when I disabled the monitoring module. Don’t know, if you can actually enable the grafana module without enabling the monitoring module. There is also an PR open to fix this. Somebody has to merge it…

1 Like

I’m not 100% sure to be honest, due to limited ressources I’m just trying to copy the running installation to not interupt the “service” I’m providing. Its vital that data collection into influxdb does not stop, so we can collect historical data over the project runtime.

So you say, I don’t need ido-mysql anymore - I assume the dataflow is icinga → (feature influxdb) → influxdb and thats it?

So, did some quick testing: with monitoring module OR ido-mysql disabled, I do not see any updates in the influxdb anymore.

So, according to my quick test just now I do need ido-mysql and the monitoring module to feed performance data into influxdb. If there is any other way, I’d be interested. As said, I need to keep the consitency and don’t break the data rows.
So, its: icinga → monitoring → ido-mysql → influxdb (at least looks like it)
and the other way around: influxdb → grafana → icingaweb2

When you switched off the grafana module, how do you get your graphs into the icingaweb2 dashboard?

So, as a final note for today: you guys are right, ido-mysql and monitoring are not needed. Grafana with influxdb works fine without, I even got the integration running using iframes. The api error was a wrong password. Had wrong configs in my docker start script…

However, when I want to change the time frame of the graph, I get the hint to enable monitoring. Will check that next week.

looks like Error "Enabling the monitoring module might help!" when changing the time interval in the embebed graph in icingadb module · Issue #295 · Mikesch-mp/icingaweb2-module-grafana · GitHub

1 Like