Icinga-nagvis has an uncaught error in class RestrictionHelper

Good afternoon folks,

After successfully installing nagvis 1.9.17 on my single stack icinga2/icingaweb server, I tried to complete by installing and activating the icinga-nagvis integration module.

Downloaded the module and installed into the nagvis directory under my /usr/share/icingaweb2/modules/nagvis directory.

Unfortunately when I go back into icingaweb to activate the module, I get the attached error.

I have checked folder and file permissions, nothing screaming out as incorrect. if I try and activate the module via icingacli, it breaks the ui to the point of removing graphics from the browser, just leaving the text links.

My details are as follows:
icingaweb 2.6.2
module - icingaweb2-module-nagvis branch master.

Any suggestions to resolve ?

Did you apply the steps mentioned in https://github.com/Icinga/icingaweb2-module-nagvis/blob/master/doc/02-Installation.md#php-code-integration?

Sorry for delay in response, tried switching all php to fpm by creating the stated php-fpm.conf file. No success.
tried adjusting the session.save_path and restarting php/httpd. No success.
also tried adding the include_path to php.ini. No success.

Could this be a permissions issue ? During investigation I discovered our ansible role for installing icingaweb2 also sets the permissions for the /usr/share/icingaweb2 to apache:icingaweb2. Should this be something different ?

Appreciate the above point may have no bearing, just raising for context.